1. 程式人生 > >POJ-2421-Constructing Roads(最小生成樹 普利姆)

POJ-2421-Constructing Roads(最小生成樹 普利姆)

connected number this brush first cst 數字 main memory

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 26694 Accepted: 11720

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

題意:題意十分簡單粗暴,首行給出N,接著是個N*N的矩陣,map[i][j]就代表i到j的權值。接著給出Q,下面Q行,每行兩個數字A,B,代表A到B,B到A的權值為0。最後輸出最小生成樹的權值和就行。

思路:由於是稠密圖,所以選用普利姆算法比較合適,
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define N 110
#define M 0x3f3f3f3f//用一個大值表示兩點不通 

int map[N][N];
int vis[N],dst[N];//vis標已加入MST的點,dst存放各點到MST的最小距離 
int n,q;

void init()//初始圖 
{
	int i,j;
	
	for (i=0;i<N;i++)
	{
		for (j=0;j<N;j++)
		{
			i==j?map[i][j]=0:map[i][j]=M;//自己到自己的點距離為0 
		}
	}
	memset(vis,0,sizeof(vis));
	memset(dst,0,sizeof(dst));
}

void prime()
{
	int ans=0,i,min,j,k,point;
	
	vis[1]=1;//1放入MST 
	for (i=1;i<=n;i++)
	{
		dst[i]=map[i][1];//dst初始化 
	}
	
	for (i=1;i<=n;i++)
	{
		min=M;
		for (j=1;j<=n;j++)//找距MST最近的點 
		{
			if (vis[j]==0&&min>dst[j])
			{
				min=dst[j];
				point=j;
			}
		}
		if (min==M)//沒有連通點 
		{
			break;
		 }
		 
		vis[point]=1;//把距MST最近的點加入MST 
		ans=ans+dst[point];
		
		for (k=1;k<=n;k++)//更新各點到MST的最小距離 
		{
			if (vis[k]==0&&dst[k]>map[k][point])
			{
				dst[k]=map[k][point];
			} 
		}
	}
	printf("%d\n",ans);
}

int main()
{
	int i,j,x,y;
	
	scanf("%d",&n);
	init();
	for (i=1;i<=n;i++)
	{
		for (j=1;j<=n;j++)
		{
			scanf("%d",&map[i][j]);
		}
	}
	
	scanf("%d",&q);
	for (i=0;i<q;i++)
	{
		scanf("%d%d",&x,&y);//已連通的兩點權為0 
		map[x][y]=0;
		map[y][x]=0;
	}
	
	prime();
	
	return 0;
} 

POJ-2421-Constructing Roads(最小生成樹 普利姆)