1. 程式人生 > >hdu 1026 Ignatius and the Princess I(BFS+優先隊列)

hdu 1026 Ignatius and the Princess I(BFS+優先隊列)

while des strong ati not whole 定義 bit style

傳送門:

http://acm.hdu.edu.cn/showproblem.php?pid=1026

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21841 Accepted Submission(s): 7023
Special Judge


Problem Description The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166‘s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166‘s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output For each test case, you should output "God please help our poor hero." if Ignatius can‘t reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.

Sample Output It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH 分析: bfs具有貪心的特性 即有路徑優先的特性,但是外面不是要路徑優先,而是要時間優先 所以這裏要自己定義一下優先隊列的優先條件 第一次寫bfs加優先隊列的題 完全是模仿別人的代碼 也沒有理解 不過還是紀念一下,本類型題的第一發 code:
#include<bits/stdc++.h>
using namespace std;
#define max_v 105
#define INF 99999999
struct node
{
    int x,y;
    int sum;
    friend bool operator<(const node &a,const node &b)
    {
        return a.sum>b.sum;
    }
};
struct nn
{
    int x,y;
}pre[max_v][max_v];
int f[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char s[max_v][max_v];
int ptr[max_v][max_v];
priority_queue <node> Q;
int n,m,ans;
int bfs()
{
    int i;
    while(!Q.empty())
    {
        Q.pop();
    }
    node temp,tx;
    temp.x=0;
    temp.y=0;
    temp.sum=0;
    ptr[0][0]=0;
    Q.push(temp);
    while(!Q.empty())
    {
        node t=Q.top();
        Q.pop();
        if(t.x==n-1&&t.y==m-1)
        {
            ans=t.sum;
            return 1;
        }
        for(i=0;i<4;i++)
        {
            int a=t.x+f[i][0];
            int b=t.y+f[i][1];
            if(a>=0&&a<n&&b>=0&&b<m&&s[a][b]!=X)
            {
                tx.x=a;
                tx.y=b;
                tx.sum=t.sum+1;
                if(s[a][b]!=.)
                    tx.sum+=s[a][b]-0;
                if(ptr[a][b]>tx.sum)
                {
                    ptr[a][b]=tx.sum;
                    pre[a][b].x=t.x;
                    pre[a][b].y=t.y;
                    Q.push(tx);
                }
            }
        }
    }
    return 0;
}
void pf(int x,int y)
{
    int i;
    if(x==0&&y==0)
        return ;
    pf(pre[x][y].x,pre[x][y].y);
    printf("%ds:(%d,%d)->(%d,%d)\n",ptr[pre[x][y].x][pre[x][y].y]+1,pre[x][y].x,pre[x][y].y,x,y);
    if(s[x][y]!=.)
    {
        for(i=1;i<=s[x][y]-0;i++)
        {
            printf("%ds:FIGHT AT (%d,%d)\n",ptr[pre[x][y].x][pre[x][y].y]+1+i,x,y);
        }
    }
}
int main()
{
    int i,j;
    while(~scanf("%d %d",&n,&m))
    {
        for(i=0;i<n;i++)
        {
            scanf("%s",s[i]);
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                ptr[i][j]=INF;
            }
        }
        if(bfs())
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",ans);
            pf(n-1,m-1);
        }else
        {
            printf("God please help our poor hero.\n");
        }
        printf("FINISH\n");
    }
    return 0;
}

hdu 1026 Ignatius and the Princess I(BFS+優先隊列)