1. 程式人生 > >POJ 2728 Desert King (01分數規劃)

POJ 2728 Desert King (01分數規劃)

clas ostream test tro 一個 false printf ans tput

                Desert King
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions:29775 Accepted: 8192

Description

David the Great has just become the king of a desert country. To win the respect of his people, he decided to build channels all over his country to bring water to every village. Villages which are connected to his capital village will be watered. As the dominate ruler and the symbol of wisdom in the country, he needs to build the channels in a most elegant way.

After days of study, he finally figured his plan out. He wanted the average cost of each mile of the channels to be minimized. In other words, the ratio of the overall cost of the channels to the total length must be minimized. He just needs to build the necessary channels to bring water to all the villages, which means there will be only one way to connect each village to the capital.

His engineers surveyed the country and recorded the position and altitude of each village. All the channels must go straight between two villages and be built horizontally. Since every two villages are at different altitudes, they concluded that each channel between two villages needed a vertical water lifter, which can lift water up or let water flow down. The length of the channel is the horizontal distance between the two villages. The cost of the channel is the height of the lifter. You should notice that each village is at a different altitude, and different channels can‘t share a lifter. Channels can intersect safely and no three villages are on the same line.

As King David‘s prime scientist and programmer, you are asked to find out the best solution to build the channels.

Input

There are several test cases. Each test case starts with a line containing a number N (2 <= N <= 1000), which is the number of villages. Each of the following N lines contains three integers, x, y and z (0 <= x, y < 10000, 0 <= z < 10000000). (x, y) is the position of the village and z is the altitude. The first village is the capital. A test case with N = 0 ends the input, and should not be processed.

Output

For each test case, output one line containing a decimal number, which is the minimum ratio of overall cost of the channels to the total length. This number should be rounded three digits after the decimal point.

Sample Input

4
0 0 0
0 1 1
1 1 2
1 0 3
0

Sample Output

1.000

思路
在這個題裏面,用到了我上一篇博客裏面說到的,01分數規劃算法,在寫一遍復習這個算法吧,就是用一個估計值,乘上物品的權值,在於物品的價值作比較,這個比較的過程,不止一個節點的比較,所以要將物品的權值和價值累和,在進行比較,這裏的權值和價值都沒有再乘或除裏面,所以這裏可以將其累和。如果比較的結果,是價值大了,就調小x,否則,調大x;

除此之外,我要噴一下POJ,說好的數據範圍1-1000,我的數組開了1024,tle了一晚上,之後改成了1066,就過了。。過了、、、過了。。。


代碼
#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define inf 1000000000
using namespace std;
int x[1066],y[1066],h[1066];
bool book[1066];
int n,t;
long double d[1066][1066],dis[1066],z[1066][1066],w[1066][1066];;
long double Abs(long double x){return (x>=0)?x:-x;}
bool prim(double x)
{
    for(int i=1;i<=n;i++){
        dis[i]=inf;
        book[i]=false;
        for(int j=i+1;j<=n;j++){
            d[i][j]=d[j][i]=z[i][j]-x*w[i][j];
        }
    }
    dis[1]=0;
    dis[0]=inf;
    long double ans=0;
    for(int j=1;j<=n;j++){
        int t=0;
        for(int i=1;i<=n;i++){
            if(!book[i]&&dis[t]>dis[i]){t=i;}
        }
        ans+=dis[t];book[t]=true;
        for(int i=1;i<=n;i++){
            if(!book[i]&&d[t][i]<dis[i]){
                dis[i]=d[t][i];
            }
        }

    }
    return ans>0;
}

int main()
{
    while(scanf("%d",&n)!=EOF&&n){
        for(int i=1;i<=n;i++){
            scanf("%d%d%d",&x[i],&y[i],&h[i]);
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                w[i][j]=sqrt((long double)((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j])));
                z[i][j]=Abs(h[i]-h[j]);
            }
        }
        long double l=0,r=1000000000;
        while(r-l>1e-6){
            double mid=(l+r)/2;
            if(prim(mid)){l=mid;}
            else r=mid;
        }
        printf("%.3f\n",(double)l);
    }
}

 

POJ 2728 Desert King (01分數規劃)