1. 程式人生 > >1025 PAT Ranking[排序][一般]

1025 PAT Ranking[排序][一般]

ostream orm git neo 指向 時有 bool -m 怎麽

1025 PAT Ranking (25)(25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

題目大意:將多個考場中的考生按分數排序,輸出格式是:id,最終排名,所屬考場,考場排名。

AC代碼:

#include <cstdio>
#include<iostream>
#include <string.h>
#include<algorithm>

using namespace std;
struct Stu{
    string id;
    int lno,lrank,fin,score;
}stu[30000];
bool cmp(Stu& a, Stu& b){
    if(a.score>b.score)return true;
    else if(a.score==b.score) {
        if(a.id<b.id) return true;
        else return false;
    }
    return false;
}
int main() {
   int n,m;
   cin>>n;
   string s;
   int score,ct=0;
   for(int i=0;i<n;i++){
        cin>>m;
        for(int j=0;j<m;j++){
            cin>>s>>score;
            stu[ct].id=s;
            stu[ct].lno=i+1;
            stu[ct++].score=score;
        }
        sort(stu+ct-m,stu+ct,cmp);
        stu[ct-m].lrank=1;
        int p=2;
        for(int j=ct-m+1;j<ct;j++){
            stu[j].lrank=p++;
            if(stu[j].score==stu[j-1].score)
                stu[j].lrank=stu[j-1].lrank;
        }
//        for(int j=ct-m;j<ct;j++){
//            cout<<stu[j].id<<" "<<stu[j].fin<<" "<<stu[j].lno<<" "<<stu[j].lrank<<‘\n‘;
//        }
   }
    sort(stu,stu+ct,cmp);
    stu[0].fin=1;
    for(int i=1;i<ct;i++){
        stu[i].fin=i+1;
        if(stu[i].score==stu[i-1].score)
            stu[i].fin=stu[i-1].fin;
    }
    cout<<ct<<\n;
    for(int i=0;i<ct;i++){
        cout<<stu[i].id<<" "<<stu[i].fin<<" "<<stu[i].lno<<" "<<stu[i].lrank<<\n;
    }
    return 0;
}

1.提交了四五次。

2.更加深入理解了sort函數,第一個參數是起點,第二個參數是終點,第三個是排序函數。註意第二個不是排序長度,而是指向排序終點的下一個。

3.提交時一定要把自己的中間輸出給註釋掉。

4.還要註意在排序時有相同的數怎麽辦,這個是在大神代碼裏學到的。

1025 PAT Ranking[排序][一般]