1. 程式人生 > >HDU 1880 魔咒詞典 (Hash)

HDU 1880 魔咒詞典 (Hash)

ron %s scan -- clas break emp tro sample

魔咒詞典

Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16641 Accepted Submission(s): 3916


Problem Description 哈利波特在魔法學校的必修課之一就是學習魔咒。據說魔法世界有100000種不同的魔咒,哈利很難全部記住,但是為了對抗強敵,他必須在危急時刻能夠調用任何一個需要的魔咒,所以他需要你的幫助。

給你一部魔咒詞典。當哈利聽到一個魔咒時,你的程序必須告訴他那個魔咒的功能;當哈利需要某個功能但不知道該用什麽魔咒時,你的程序要替他找到相應的魔咒。如果他要的魔咒不在詞典中,就輸出“what?”

Input 首先列出詞典中不超過100000條不同的魔咒詞條,每條格式為:

[魔咒] 對應功能

其中“魔咒”和“對應功能”分別為長度不超過20和80的字符串,字符串中保證不包含字符“[”和“]”,且“]”和後面的字符串之間有且僅有一個空格。詞典最後一行以“@END@”結束,這一行不屬於詞典中的詞條。
詞典之後的一行包含正整數N(<=1000),隨後是N個測試用例。每個測試用例占一行,或者給出“[魔咒]”,或者給出“對應功能”。

Output 每個測試用例的輸出占一行,輸出魔咒對應的功能,或者功能對應的魔咒。如果魔咒不在詞典中,就輸出“what?”

Sample Input [expelliarmus] the disarming charm [rictusempra] send a jet of silver light to hit the enemy [tarantallegra] control the movement of one‘s legs [serpensortia] shoot a snake out of the end of one‘s wand [lumos] light the wand [obliviate] the memory charm [expecto patronum] send a Patronus to the dementors [accio] the summoning charm @END@ 4 [lumos] the summoning charm [arha] take me to the sky

Sample Output light the wand accio what? what? 思路:
我的第二道hash題,第一道是使用map來存hash值,但是這題用map就會爆內存,所以要使用結構體來存,找的時候二分。 map只是寫起來方便罷了,它的復雜度是nlogn,而二分同樣是nlogn,不知道為什麽用map會爆內存,但是以後用map要小心了。 代碼:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
using namespace std;
typedef unsigned long long ll;
long long seed = 9731;
char s[40];
struct Hash
{
    ll num;
    string s;

    bool operator<(const Hash x)const
    {
        return x.num<num;
    }

}a[100086],b[100086],exa;
int main()
{
    string pos,pre;
    char c;
    int nn=0;
    while(true){
        scanf("%c",&c);
        if(c==‘@‘){break;}
        if(c!=‘[‘){continue;}
        ll ss=seed,num=0;
        pre.clear();
        while(true){
            scanf("%c",&c);
            if(c==‘]‘){break;}
            num+=c*ss;pre.push_back(c);
            ss*=ss;
        }
        getchar();
        getline(cin,pos);
        a[nn].num=num;
        a[nn].s=pos;
        int l=pos.length();
        ss=seed,num=0;
        for(int i=0;i<l;i++){
            num+=pos[i]*ss;
            ss*=ss;
        }
        b[nn].num=num;
        b[nn].s=pre;
        nn++;
    }
    scanf("%s",s);
    int q;
    scanf("%d",&q);
    sort(a,a+nn);
    sort(b,b+nn);
    getchar();
    while(q--){
        getline(cin,pos);
        ll num=0,ss=seed;
        int l=pos.length();
        if(pos[0]==‘[‘){
            for(int i=1;i<l-1;i++){
                num+=ss*pos[i];
                ss*=ss;
            }
            int y;
            exa.num=num;//cout<<num<<endl;
            y=lower_bound(a,a+nn,exa)-a;
            if(a[y].num!=num){cout<<"what?"<<endl;}
            else cout<<a[y].s<<endl;
        }
        else{
            for(int i=0;i<l;i++){
                num+=ss*pos[i];
                ss*=ss;
            }
            int y;

            exa.num=num;
            y=lower_bound(b,b+nn,exa)-b;
            if(b[y].num!=num){cout<<"what?"<<endl;}
            else cout<<b[y].s<<endl;
        }
    }
}

  

HDU 1880 魔咒詞典 (Hash)