1. 程式人生 > >A1035 Password (20)(20 分)

A1035 Password (20)(20 分)

pwd ace ica one test times rand 遇到 prepare

A1035 Password (20)(20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (<= 1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line "There are N accounts and no account is modified" where N is the total number of accounts. However, if N is one, you must print "There is 1 account and no account is modified" instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

思考

c++的引用很方便,傳遞參數,傳遞了操作對象本身,靈魂附體。

c語言沒有引用,只能指針取地址。

AC代碼

c語言

#include <stdio.h>
#include <string.h>
#include <stdbool.h>
struct node {
    char name[20], password[20];
    bool ischange;
}T[1005];
/*在C語言中是不存在引用的,也就是說C語言中&表示的不是引用,僅僅是取地址符。所以錯誤提示就是告訴你&在這裏用的不對,那怎麽解決呢?

首先介紹一個正規的解決方法:用指針來取代引用,在主函數中傳進來地址;*/
void crypt(struct node* t, int* cnt) {//c語言結構體必須加struct,typedef可解決此類問題
    int len = strlen(t->password);
    for(int i = 0; i < len; i++) {
        if(t->password[i] == ‘1‘) {
            t->password[i] = ‘@‘;
            t->ischange = true;
        } else if(t->password[i] == ‘0‘) {
            t->password[i] = ‘%‘;
            t->ischange = true;
        } else if(t->password[i] == ‘l‘) {
            t->password[i] = ‘L‘;
            t->ischange = true;
        } else if(t->password[i] == ‘O‘) {
            t->password[i] = ‘o‘;
            t->ischange = true;
        }
    }
    if(t->ischange) {
        (*cnt)++;//優先級很重要,先解指針,再自增1,遇到優先級沒把握,加括號,都加上 
    }
}

int main() {
    int n, cnt = 0;
    scanf("%d", &n);
    for(int i = 0; i < n; i++) {
        scanf("%s %s", T[i].name, T[i].password);
        T[i].ischange = false;//初始化為未修改 
    }
    for(int i = 0; i < n; i++) {
        crypt(&T[i], &cnt);
    }
    if(cnt == 0) {
        if(n == 1) printf("There is %d account and no account is modified", n);
        else {
            printf("There are %d accounts and no account is modified", n);
        }
    }else {
        printf("%d\n", cnt);
        for(int i = 0; i < n; i++) {
            if(T[i].ischange) {
                printf("%s %s\n", T[i].name, T[i].password);
            }
        }
    }
    return 0;
}

c++

#include <cstdio>
#include <cstring>
struct node {
    char name[20], password[20];
    bool ischange;
}T[1005];

void crypt(node& t, int& cnt) {//引用,可以對傳入參數進行修改 
    int len = strlen(t.password);
    for(int i = 0; i < len; i++) {
        if(t.password[i] == ‘1‘) {
            t.password[i] = ‘@‘;
            t.ischange = true;
        } else if(t.password[i] == ‘0‘) {
            t.password[i] = ‘%‘;
            t.ischange = true;
        } else if(t.password[i] == ‘l‘) {
            t.password[i] = ‘L‘;
            t.ischange = true;
        } else if(t.password[i] == ‘O‘) {
            t.password[i] = ‘o‘;
            t.ischange = true;
        }
    }
    if(t.ischange) {
        cnt++;
    }
}

int main() {
    int n, cnt = 0;
    scanf("%d", &n);
    for(int i = 0; i < n; i++) {
        scanf("%s %s", T[i].name, T[i].password);
        T[i].ischange = false;
    }
    for(int i = 0; i < n; i++) {
        crypt(T[i], cnt);
    }
    if(cnt == 0) {
        if(n == 1) printf("There is %d account and no account is modified", n);
        else {
            printf("There are %d accounts and no account is modified", n);
        }
    }else {
        printf("%d\n", cnt);
        for(int i = 0; i < n; i++) {
            if(T[i].ischange) {
                printf("%s %s\n", T[i].name, T[i].password);
            }
        }
    }
    return 0;
}

A1035 Password (20)(20 分)