1. 程式人生 > >HDU 1711 Number Sequence (KMP簡單題)

HDU 1711 Number Sequence (KMP簡單題)

bmi AMM several rip case ive sts -- 沒有

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39408 Accepted Submission(s): 16269


Problem Description Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input 2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output 6 -1

Source HDU 2007-Spring Programming Contest

Recommend lcy | We have carefully selected several similar problems for you: 1358 3336 1686 3746 2222 分析: 題目意思: 給你一個長的文本串,一個短的模板串 問你模板串匹在文本串中匹配到的位置 沒有匹配到的話,輸出-1 跑kmp就好
#include<cstdio>
#include<iostream>
#include<cstring>
#include<memory>
using namespace std;
int moban[1000005],wenben[1000005];
int next1[1000005];
int sum;
void getnext(int* s,int* next1,int m)
{
    next1[0]=0;
    next1[1]=0;
    for(int i=1;i<m;i++)
    {
        int j=next1[i];
        while(j&&s[i]!=s[j])
            j=next1[j];
        if(s[i]==s[j])
            next1[i+1]=j+1;
        else
            next1[i+1]=0;
    }
}
void kmp(int* ss,int* s,int* next1,int n,int m)
{
    int ans=-1;
    getnext(s,next1,m);
    int j=0;
    for(int i=0;i<n;i++)
    {
        while(j&&s[j]!=ss[i])
            j=next1[j];
        if(s[j]==ss[i])
            j++;
        if(j==m)
        {
            ans=i-m+2;
            break;
        }
    }
    printf("%d\n",ans);
}
int main()
{
    int t;
    scanf("%d",&t);
    int n,m;
    while(t--)
    {
        scanf("%d %d",&n,&m);
        for(int i=0;i<n;i++)
        scanf("%d",&wenben[i]);
        for(int i=0;i<m;i++)
        scanf("%d",&moban[i]);
        kmp(wenben,moban,next1,n,m);
    }
    return 0;
}

HDU 1711 Number Sequence (KMP簡單題)