1. 程式人生 > >HDU 3047 Zjnu Stadium(帶權並查集,難想到)

HDU 3047 Zjnu Stadium(帶權並查集,難想到)

union blank then submit urn lin lock sts count

M - Zjnu Stadium Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u Submit Status

Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input

There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output

For every case:
Output R, represents the number of incorrect request.

Sample Input

10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100

Sample Output

2

Hint

 Hint: (PS: the 5th and 10th requests are incorrect) 
         

一個類似的題:
https://www.cnblogs.com/yinbiao/p/9460772.html

code:
#include<queue>
#include<set>
#include<cstdio>
#include <iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<map>
#include<string>
#include<string.h>
#include<memory>
using namespace std;
#define max_v 50005
#define INF 9999999
int pa[max_v];
int sum[max_v];
int n,m;
int ans;
void init()
{
    for(int i=0;i<=n;i++)
    {
        pa[i]=i;
        sum[i]=0;
    }
}
int find_set(int x)
{
    if(pa[x]!=x)
    {
        int t=pa[x];
        pa[x]=find_set(pa[x]);
        sum[x]+=sum[t];//!!!
    }
    return pa[x];
}
void union_set(int a,int b,int v)
{
    int x=find_set(a);
    int y=find_set(b);
    if(x==y)
    {
        if(sum[a]-sum[b]!=v)//!!!
            ans++;
    }else
    {
        pa[x]=y;
        sum[x]=sum[b]-sum[a]+v;//!!!
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        int x,y,w;
        ans=0;
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&x,&y,&w);
            union_set(x,y,w);
        }
        printf("%d\n",ans);
    }
    return 0;
}



HDU 3047 Zjnu Stadium(帶權並查集,難想到)