1. 程式人生 > >POJ 3468 A Simple Problem with Integers(線段樹模板之區間增減更新 區間求和查詢)

POJ 3468 A Simple Problem with Integers(線段樹模板之區間增減更新 區間求和查詢)

return string ali accept numbers other map nts contain

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 140120 Accepted: 43425
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa

, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers. 分析: 線段樹模板之區間增減更新 區間求和查詢 寫板子好爽啊!!!
code:
#include<stdio.h>
#include<iostream>
#include<vector>
#include <cstring>
#include <stack>
#include <cstdio>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <set>
#include <map>
#include<string>
#include<math.h>
#define max_v 100005
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
LL sum[max_v<<2],add[max_v<<2];
struct node
{
    int l,r;
    int mid()
    {
        return (l+r)/2;
    }
}tree[max_v<<2];

void push_up(int rt)//向上更新
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void push_down(int rt,int m)//向下更新
{
    if(add[rt])//若有標記,則將標記向下移動一層
    {
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];

        sum[rt<<1]+=add[rt]*(m-(m>>1));
        sum[rt<<1|1]+=add[rt]*(m>>1);
        add[rt]=0;//取消本層標記
    }
}
void build(int l,int r,int rt)
{
    tree[rt].l=l;
    tree[rt].r=r;
    add[rt]=0;

    if(l==r)
    {
        scanf("%I64d",&sum[rt]);
        return ;
    }

    int m=tree[rt].mid();
    build(lson);
    build(rson);
    push_up(rt);//向上更新
}
void update(int c,int l,int r,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    {
        add[rt]+=c;
        sum[rt]+=(LL)c*(r-l+1);
        return ;
    }

    if(tree[rt].l==tree[rt].r)
        return ;

    push_down(rt,tree[rt].r-tree[rt].l+1);//向下更新

    int m=tree[rt].mid();
    if(r<=m)
        update(c,l,r,rt<<1);
    else if(l>m)
        update(c,l,r,rt<<1|1);
    else
    {
        update(c,l,m,rt<<1);
        update(c,m+1,r,rt<<1|1);
    }
    push_up(rt);//向上更新
}
LL getsum(int l,int r,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==r)
        return sum[rt];

    push_down(rt,tree[rt].r-tree[rt].l+1);//向下更新

    int m=tree[rt].mid();
    LL res=0;
    if(r<=m)
        res+=getsum(l,r,rt<<1);
    else if(l>m)
        res+=getsum(l,r,rt<<1|1);
    else
    {
        res+=getsum(l,m,rt<<1);
        res+=getsum(m+1,r,rt<<1|1);
    }
    return res;
}
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        build(1,n,1);//1到n建樹 rt為1

        while(m--)
        {
            char str[5];
            int a,b,c;
            scanf("%s",str);
            if(str[0]==Q)
            {
                scanf("%d %d",&a,&b);
                printf("%I64d\n",getsum(a,b,1));
            }else
            {
                scanf("%d %d %d",&a,&b,&c);
                update(c,a,b,1);
            }
        }
    }
    return 0;
}
/*
區間更新:增減更新
區間查詢:求和
*/

POJ 3468 A Simple Problem with Integers(線段樹模板之區間增減更新 區間求和查詢)