1. 程式人生 > >POJ 1416 Shredding Company【dfs入門】

POJ 1416 Shredding Company【dfs入門】

並且 output resp ret poj 兩種 mat order case

題目傳送門:http://poj.org/problem?id=1416

Shredding Company

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6860 Accepted: 3710

Description

You have just been put in charge of developing a new shredder for the Shredding Company Although a "normal" shredder would just shred sheets of paper into little pieces so that the contents would become unreadable, this new shredder needs to have the following unusual basic characteristics.

1.The shredder takes as input a target number and a sheet of paper with a number written on it.

2.It shreds (or cuts) the sheet into pieces each of which has one or more digits on it.

3.The sum of the numbers written on each piece is the closest possible number to the target number, without going over it.

For example, suppose that the target number is 50, and the sheet of paper has the number 12346. The shredder would cut the sheet into four pieces, where one piece has 1, another has 2, the third has 34, and the fourth has 6. This is because their sum 43 (= 1 + 2 + 34 + 6) is closest to the target number 50 of all possible combinations without going over 50. For example, a combination where the pieces are 1, 23, 4, and 6 is not valid, because the sum of this combination 34 (= 1 + 23 + 4 + 6) is less than the above combination‘s 43. The combination of 12, 34, and 6 is not valid either, because the sum 52 (= 12 + 34 + 6) is greater than the target number of 50.
技術分享圖片

Figure 1. Shredding a sheet of paper having the number 12346 when the target number is 50


There are also three special rules :

1.If the target number is the same as the number on the sheet of paper, then the paper is not cut.

For example, if the target number is 100 and the number on the sheet of paper is also 100, then

the paper is not cut.

2.If it is not possible to make any combination whose sum is less than or equal to the target number, then error is printed on a display. For example, if the target number is 1 and the number on the sheet of paper is 123, it is not possible to make any valid combination, as the combination with the smallest possible sum is 1, 2, 3. The sum for this combination is 6, which is greater than the target number, and thus error is printed.

3.If there is more than one possible combination where the sum is closest to the target number without going over it, then rejected is printed on a display. For example, if the target number is 15, and the number on the sheet of paper is 111, then there are two possible combinations with the highest possible sum of 12: (a) 1 and 11 and (b) 11 and 1; thus rejected is printed. In order to develop such a shredder, you have decided to first make a simple program that would simulate the above characteristics and rules. Given two numbers, where the first is the target number and the second is the number on the sheet of paper to be shredded, you need to figure out how the shredder should "cut up" the second number.

Input

The input consists of several test cases, each on one line, as follows :

tl num1
t2 num2
...
tn numn
0 0

Each test case consists of the following two positive integers, which are separated by one space : (1) the first integer (ti above) is the target number, (2) the second integer (numi above) is the number that is on the paper to be shredded.

Neither integers may have a 0 as the first digit, e.g., 123 is allowed but 0123 is not. You may assume that both integers are at most 6 digits in length. A line consisting of two zeros signals the end of the input.

Output

For each test case in the input, the corresponding output takes one of the following three types :

sum part1 part2 ...
rejected
error

In the first type, partj and sum have the following meaning :

1.Each partj is a number on one piece of shredded paper. The order of partj corresponds to the order of the original digits on the sheet of paper.

2.sum is the sum of the numbers after being shredded, i.e., sum = part1 + part2 +...

Each number should be separated by one space.
The message error is printed if it is not possible to make any combination, and rejected if there is
more than one possible combination.
No extra characters including spaces are allowed at the beginning of each line, nor at the end of each line.

Sample Input

50 12346
376 144139
927438 927438
18 3312
9 3142
25 1299
111 33333
103 862150
6 1104
0 0

Sample Output

43 1 2 34 6
283 144 139
927438 927438
18 3 3 12
error
21 1 2 9 9
rejected
103 86 2 15 0
rejected

Source

Japan 2002 Kanazawa

題意概括:

給一個目標值 T , 和一串數字(最多六個),切分這串數字使得最後切出來的數字和最接近T(但不可以大於T)

一、如果目標值和原數字值相同不可以切分;

二、如果最小的切分結果都大於 T 則輸出 “error”;

三、如果切分的最優結果不唯一則輸出“rejected”;

四、如果可切分並且結果唯一,輸出最優值和切分結果。

解題思路:

我們知道如果原字串長度為 N ,則我們最多可以切 N-1 次;

根據數據範圍可直接DFS,無需剪枝,暴力遍歷所有可能找出最優值。

AC code:

///POJ 1416 dfs
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#define INF 0x3f3f3f3f
#define ll long long int
using namespace std;
int dis[1000000];
int num[7], t[7], v[7];
char ch[10];
int max_N, cnt;
int tar, top, N, len;

void dfs(int x, int m, int cap)
{
    int y;
    bool flag;
    if(x==len)      ///到達末尾
    {
        if(max_N > m) return;      ///當前值小於最優值
        flag = 0;
        for(int i = 0; i < cap; i++) ///判斷兩種切分是否相同
            if(t[i]!=v[i]) flag = 1;
        if(max_N < m)       ///當前值優於最優值
        {
            max_N = m;
            cnt = cap;
            for(int i = 0; i < cap; i++) t[i]=v[i];
        }
        if(flag) dis[m]++;  ///記錄最優值 m 的出現次數
        return;
    }
    y = 0;
    for(int i = x; i < len; i++)  ///從 X 開始遍歷當前這一段的不同長度的結果
    {
        y = y*10+num[i];
        if(y+m<=tar)               ///這一段可以加上num[ i ]
        {
            v[cap] = y;
            dfs(i+1, y+m, cap+1);  ///進入下一段
        }
        else break;
    }
}

int main()
{
    while(~scanf("%d", &tar))
    {
        scanf("%s", &ch);
        if(tar == 0 && ch[0] == 0) break;
        len = 0;
        memset(dis, 0, sizeof(dis));
        memset(v, 0, sizeof(v));
        memset(t, 0, sizeof(t));
        int sum = 0;
        for(int i = 0; ch[i] != \0; i++)
        {
            num[i] = ch[i]-0;
            N = N*10+num[i];
            sum+=num[i];
            len++;
        }
        if(sum > tar || (sum == tar && top>4)) {printf("error\n"); continue;}
        if(N == tar) {printf("%d\n", N); continue;}
        max_N = 0, cnt = 0;
        dfs(0, 0, 0);
        if(dis[max_N]!=1) printf("rejected\n");
        else
        {
            printf("%d", max_N);
            for(int i = 0; i < cnt; i++)
                printf(" %d", t[i]);
            puts("");
        }
    }
    return 0;
}

POJ 1416 Shredding Company【dfs入門】