1. 程式人生 > >HUD Is It A Tree?!!!!!)

HUD Is It A Tree?!!!!!)

stdio.h cor nes std case memset null div turn

這個是一個非常惡心的題,剛開始以為是POJ的題,結果發現不是,一直都是超時。上題吧

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

技術分享圖片技術分享圖片技術分享圖片



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input 6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1

Sample Output Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree. 技術分享圖片
#include<stdio.h>
#include<string.h>
const int INF=1010;
int par[INF],ran[INF],sum;
bool t;
int find(int x)
{
    if(par[x]==x)
        return x;
    return par[x]=find(par[x]);
}
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
        par[x]=y;
    else
        t=true;
}
int main()
{
    int x,y,m=1;
    while(1)
    {
        memset(par,0,sizeof(par));
        memset(ran,0,sizeof(ran));
        t=false;
        while(scanf("%d%d",&x,&y)&&(x||y))
        {
            if(x<0&&y<0)
                return 0;
            if(par[x]==0)
                par[x]=x;
            if(par[y]==0)
                par[y]=y;
            unite(x,y);
            ran[y]++;
        }
        if(t)
            printf("Case %d is not a tree.\n",m++);
        else
        {
            int sum=0,num=0;
            for(int i=1; i<INF; i++)
            {
                if(par[i]==i)
                {
                    sum++;
                    if(sum>1)
                    {
                        num=1;
                        break;
                    }
                }
                if(ran[i]>1)
                {
                    num=1;
                    break;
                }
            }
            if(num)
                printf("Case %d is not a tree.\n",m++);
            else
                printf("Case %d is a tree.\n",m++);
        }
    }
    return 0;
}
View Code

HUD Is It A Tree?!!!!!)