1. 程式人生 > >PAT 1064 Complete Binary Search Tree[二叉樹][難]

PAT 1064 Complete Binary Search Tree[二叉樹][難]

als tom 自然 resp scanf cbt oot 根據 attr

1064 Complete Binary Search Tree (30)(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

題目大意:給出一組數,構建對應的唯一的二叉搜索樹,並且要求這棵二叉樹樹是完全二叉樹。

//看到題目感覺很懵,完全沒有做過這樣的題。

代碼來自:https://www.nowcoder.com/questionTerminal/ab6b7429f9c34880837cf4830b2434df

#include<cstdio>
#include<algorithm>
using namespace std;
int node[1010],tree[1010];
int N,pos;
void creatTree(int root){//就相當於順序著把根安排在了tree上。
    //遞歸安排上了之後自然就是層次存儲。
    if(root>N)    return;
    int lchild=root*2,rchild=root*2+1;
    creatTree(lchild);
    tree[root]=node[pos++];
    creatTree(rchild);
}
bool cmp(int a,int b){
    return a<b;
}
int main(){
    scanf("%d",&N);
    for(int i=0;i<N;i++){
        scanf("%d",&node[i]);
    }
    sort(node,node+N,cmp);//既然是二叉搜索樹,那麽排序完了之後自然就是中序遍歷。
    pos=0;
    creatTree(1);
    for(int i=1;i<=N;i++){//註意下標是從1開始計算的。
        printf("%d",tree[i]);
        if(i<N){
            printf(" ");
        }
    }
}

1.根據完全二叉樹在數組中的存儲特點,下標的特點。

2.

PAT 1064 Complete Binary Search Tree[二叉樹][難]