1. 程式人生 > >浙大pat1039 Course List for Student(25 分)

浙大pat1039 Course List for Student(25 分)

fonts 設計 output true tle sample std dice get

1039 Course List for Student(25 分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (40,000), the number of students who look for their course lists, and K (2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N?i?? (200) are given in a line. Then in the next line, N?i?? student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
作者: CHEN, Yue 單位: 浙江大學 時間限制: 600 ms 內存限制: 64 MB 代碼長度限制: 16 KB

題解:這道題就是考差哈希存儲 如果暴力肯定過不了,我用的c++自帶的map,最後一個測試點過不了,看了網上的大佬基本都用了哈希算法,我當時怕哈希沖突就沒用這個,但是網上看到還是可以設計好的哈希函數來避免沖突的

比如這個:

int getID(string name){
    int id = 0;
    for(int i=0; i<3; i++){
        id = id*26+(name[i]-‘A‘);
    }
    id = id * 10 + (name[3] - ‘0‘);
    return id;
}

  當時主要是怕序列問題 比如ABC3 和BCA3的哈希很可能一樣,但其實簡單點的操作一下就行了。學會這種哈希算法。

(來源:https://blog.csdn.net/Q_smell/article/details/82284795)

下面貼一下我的沒用哈希的map代碼,雖然最後一個測試點沒過,但是這種寫法讓我熟悉了map的操作(包括值為vector)有一定的借鑒意義。

#include <iostream>
#include <map>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
int main(int argc, char *argv[]) 
{
	vector<string>query;
	map<string,vector<int> > hash;
	int n,k;
	cin>>n>>k;
	for(int i=0;i<k;i++)
	{
		int n1,k1;
		cin>>n1>>k1;
		for(int j=0;j<k1;j++)
		{
			string s;
			cin>>s;
			hash[string(s)].push_back(n1);
		}
	}
	for(int i = 0;i<n;i++)
	{
		string tmp;
		cin>>tmp;
		
		query.push_back(tmp);
	}
	for(int  i=0;i<n;i++)
	{
		int num = hash[query[i]].size();
		sort(hash[query[i]].begin(),hash[query[i]].end());
		cout<<query[i]<<" "<<num;
		for(int j=0;j<num;j++)
		{
			cout<<" "<<hash[query[i]][j];
		}
		cout<<endl;
	}
}

  

浙大pat1039 Course List for Student(25 分)