1. 程式人生 > >POJ - 1942 D - Paths on a Grid

POJ - 1942 D - Paths on a Grid

進行 cst 類型 eno because modern HERE pat att

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he‘s explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let‘s call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:
技術分享圖片

Really a masterpiece, isn‘t it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126

2

題意:輸入n,m,代表n*m的矩陣,求從左下角到右上角的方法有多少種
技術分享圖片

思路:用我們平常的加法原理可以得出這個答案,但是n,m範圍是unsigned int我們不能開這麽大的數組

我們可以發現其實我們肯定會走n+m步,其中n步向上,m步向右,我們走上,我們路線肯定是由

n個上,m個右組成,所以我們在這求出一個組合數C(n+m,m),代表從這個路線順序裏面挑出

m個位置為向右走,用C(n+m,n)也是一樣的結果

 
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
unsigned C(unsigned n,unsigned m)//n,m的每個地方都記得用unsigned類型     
{
    if(m>n-m) m=n-m;
    unsigned t1,t2;
    t1=n;
    t2=m;
    double vis=1.0;
    while(t2>0)//用double型存儲組合數,可以每次進行約分,如果是實在是整型不好存儲的話那就只能使用這個進行約分了
    {
        vis*=(double)(t1--)/(double)(t2--);
    }
    return (unsigned)(vis+0.5);//四舍五入
}
unsigned n,m;
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(!m && !n)
            break;
        cout<<C(n+m,n)<<endl;
    }
}


POJ - 1942 D - Paths on a Grid