1. 程式人生 > >hdu 6299 Balanced Sequence (貪心)

hdu 6299 Balanced Sequence (貪心)

lin main value mathjax lose ide seq max scanf

Balanced Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6311 Accepted Submission(s): 1648


Problem Description Chiaki has n strings s1,s2,,sn consisting of ‘(‘ and ‘)‘. A string of this type is said to be balanced:

+ if it is the empty string
+ if A
and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.

Chiaki can reorder the strings and then concatenate them get a new string t. Let f(t) be the length of the longest balanced subsequence (not necessary continuous) of t. Chiaki would like to know the maximum value of f(t) for all possible t
.

Input There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1n105) -- the number of strings.
Each of the next n lines contains a string si (1|si|105) consisting of `(‘ and `)‘.
It is guaranteed that the sum of all |si|
does not exceeds 5×106.

Output For each test case, output an integer denoting the answer.

Sample Input 2 1 )()(()( 2 ) )(

Sample Output 4 2 題目大意: 給你n個由‘(‘和‘)‘組成的括號序列。要你將這n個序列整體排序使得匹配的子序列(不一定相連)最長。求最長子序列。匹配條件如下: + if it is the empty string
+ if A and B are balanced, AB is balanced,
+ if A is balanced, (A) is balanced.
貪心。 首先將每個序列中匹配的括號計數並剔除。可以看到,剩下的序列都行如")))(((((",用結構體存儲r,l,排序,就可以貪心了。 貪心方法是(其實我並不能證明,大概是基於左括號盡量往左放,vice versa的思想): 1、"))))((((" 中 ‘)‘ < ‘(‘ 的 , 按 ‘)‘ 從小到大排序 ; 2、"))))((((" 中 ‘)‘ >= ‘(‘ 的 , 按 ‘(‘ 從大到小排序 ; 技術分享圖片
//優先級排序:
//1、"))))((((" 中 ‘)‘ < ‘(‘ 的 , 按 ‘)‘ 從小到大排序 ;
//2、"))))((((" 中 ‘)‘ >= ‘(‘ 的 , 按 ‘(‘ 從大到小排序 ;

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<stack>

using namespace std;

const int maxn=100000;

char s[maxn+10];

struct tstr
{
    int r,l;
};
tstr str[maxn+10];

bool cmp(tstr a,tstr b)
{
    if(a.r<a.l&&b.r>=b.l)
        return true;
    if(b.r<b.l&&a.r>=a.l)
        return false;
    if(a.r<a.l&&b.r<b.l)
        return a.r<b.r;
    else
        return a.l>b.l;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);

        int ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",s);
            stack<char> sta;
            sta.push());//在棧底放一個‘)‘,方便後續操作
            for(int j=0;s[j]!=\0;j++)
            {
                if(s[j]==)&&sta.top()==()
                    ans+=2,sta.pop();
                else
                    sta.push(s[j]);
            }
            str[i].r=-1;str[i].l=0;
            while(!sta.empty())
            {
                if(sta.top()==()
                    str[i].l++,sta.pop();
                if(sta.top()==))
                    str[i].r++,sta.pop();
            }
        }

        sort(str,str+n,cmp);
        stack<char> sta;
        sta.push());
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<str[i].r;j++)
            {
                if(sta.top()==()
                    ans+=2,sta.pop();
                else
                    sta.push());
            }
            for(int j=0;j<str[i].l;j++)
            {
                sta.push(();
            }
        }

        printf("%d\n",ans);
    }
    return 0;
}
View Code

hdu 6299 Balanced Sequence (貪心)