1. 程式人生 > >HDU - 3949 :XOR(線性基)

HDU - 3949 :XOR(線性基)

表示 所有 integer ++ name ins several man const

XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.

InputFirst line of the input is a single integer T(T<=30), indicates there are T test cases.

For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.OutputFor each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.Sample Input

2
2
1 2
4
1 2 3 4
3
1 2 3
5
1 2 3 4 5

Sample Output

Case #1:
1
2
3
-1
Case #2:
0
1
2
3
-1

題意:給定N個數,所有集合的不同異或和中,求從小到大第K個,不存在則輸出-1。

思路:我們知道線性基可以表示用不超過64個數,表示出所有集合的異或和,那麽為0的部位不考慮,我們求第K個,就是等效表示成二進制。。。ok了。

先求線性基,得到p數組。然後把為0的忽略,並且前面的p對後面的效果求出來。 有個註意的問題就是0,因為線性基我們沒有考慮0,所以0單獨考慮,如果線性基的大小和原數組大小一樣,則可以表示出來,那麽K--;

#include<bits/stdc++.h>
#define ll long long
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define rep2(i,a,b) for(int i=a;i>=b;i--)
using namespace std;
const int maxn=100010;
ll p[66],x;
int main()
{
    int T,N,Q,Cas=0;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&N);
        rep(i,0,63) p[i]=0;
        rep(i,1,N) {
            scanf("%lld",&x);
            rep2(j,63,0){
                if(x&(1LL<<j)){
                    if(p[j]) x^=p[j];
                    else { p[j]=x;break;}
                }
            }
        }
        ll num=0,ans,K;
        rep(i,0,63) if(p[i]){
             p[num++]=p[i];
             rep(j,i+1,63) if((p[j]>>i)&1) p[j]^=p[i];
        }
        scanf("%d",&Q);
        printf("Case #%d:\n",++Cas);
        while(Q--){
            scanf("%lld",&K); if(N!=num) K--; //here,notice!考慮0的存在性
            if(K>=(1LL<<num)) puts("-1");
            else {
                ans=0;
                rep(j,0,63) {
                    if(K&(1LL<<j)) ans^=p[j]; //不能加,還是用異或,可能有尾巴,相互抵消
                }
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}

HDU - 3949 :XOR(線性基)