1. 程式人生 > >HDU - 5542 The Battle of Chibi(LIS+樹狀數組優化)

HDU - 5542 The Battle of Chibi(LIS+樹狀數組優化)

possible ould eof namespace chan panel arm int sam

The Battle of Chibi

Cao Cao made up a big army and was going to invade the whole South China. Yu Zhou was worried about it. He thought the only way to beat Cao Cao is to have a spy in Cao Cao‘s army. But all generals and soldiers of Cao Cao were loyal, it‘s impossible to convince any of them to betray Cao Cao.

So there is only one way left for Yu Zhou, send someone to fake surrender Cao Cao. Gai Huang was selected for this important mission. However, Cao Cao was not easy to believe others, so Gai Huang must leak some important information to Cao Cao before surrendering.

Yu Zhou discussed with Gai Huang and worked out
NN information to be leaked, in happening order. Each of the information was estimated to has aiai value in Cao Cao‘s opinion.

Actually, if you leak information with strict increasing value could accelerate making Cao Cao believe you. So Gai Huang decided to leak exact MM information with strict increasing value in happening order. In other words, Gai Huang will not change the order of the
NN information and just select MM of them. Find out how many ways Gai Huang could do this.

InputThe first line of the input gives the number of test cases, T(1100)T(1≤100). TT test cases follow.

Each test case begins with two numbers N(1N103)N(1≤N≤103) and M(1MN)M(1≤M≤N), indicating the number of information and number of information Gai Huang will select. Then NN numbers in a line, the ithith number ai(1ai109)ai(1≤ai≤109) indicates the value in Cao Cao‘s opinion of the ithith information in happening order.
OutputFor each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is the ways Gai Huang can select the information.

The result is too large, and you need to output the result mod by 1000000007(109+7)1000000007(109+7).
Sample Input

2
3 2
1 2 3
3 2
3 2 1

Sample Output

Case #1: 3
Case #2: 0

        
 

Hint

In the first cases, Gai Huang need to leak 2 information out of 3. He could leak any 2 information as all the information value are in increasing order. 
In the second cases, Gai Huang has no choice as selecting any 2 information is not in increasing order.

題意:求一個序列中長度為m的最長上升子序列個數。

設dp[i][j]表示以當前位置i結束的長度為j的序列個數。

容易想到O(n^3)的做法。開始想用記憶化搜索將復雜度降低一些,再加上若幹剪枝,仍然會T。

考慮到問題涉及小於(大於)某個數的數的和,因此應該想到用樹狀數組優化。

使用lower_bound將所有數離散化,還要註意在dp的同時更新樹狀數組,時間復雜度為O(n^2*logn)。

//註釋部分為優化前

#include<bits/stdc++.h>
#define MAX 1005
#define MOD 1000000007
#define lowbit(x) x&(-x)
using namespace std;
typedef long long ll;

int a[MAX],b[MAX];
int n,m;
ll dp[MAX][MAX];

ll sum(int x,int y){
    ll ans=0;
    while(1<=x){
        ans+=dp[x][y];
        ans%=MOD;
        x-=lowbit(x);
    }
    return ans;
}
void add(int x,int y,int z){
    while(x<=n){
        dp[x][y]+=z;
        dp[x][y]%=MOD;
        x+=lowbit(x);
    }
}
int main()
{
    int tt=0,t,i,j,k;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++){
            scanf("%d",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+n+1);
        for(i=1;i<=n;i++){
            a[i]=lower_bound(b+1,b+n+1,a[i])-b;
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++){
            //dp[i][1]=1;
            add(a[i],1,1);
            for(j=2;j<=m;j++){
                //dp[i][j]=dp[i-1][j];
                //for(k=1;k<i;k++){
                //    if(a[k]<a[i]){
                //        dp[i][j]+=dp[k][j-1];
                //        dp[i][j]%=MOD;
                //    }
                //}
                ll temp=sum(a[i]-1,j-1);
                add(a[i],j,temp);
            }
        }
        //printf("Case #%d: %I64d\n",++tt,dp[n][m]);
        printf("Case #%d: %I64d\n",++tt,sum(n,m));
    }
    return 0;
}

HDU - 5542 The Battle of Chibi(LIS+樹狀數組優化)