1. 程式人生 > >poj 3273Monthly Expense Time Limit: 2000MS

poj 3273Monthly Expense Time Limit: 2000MS

containe ont nim href 所有 sum clu table miss

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions:35346 Accepted: 13189

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi

≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source

USACO 2007 March Silver 題意:就是將序列劃分為k段,在所有符合要求的劃分中 要求找出某段中最大的資金 思路:我們可以直到這個值必然在所有數中最大值maxn與所有數的總和sum之間,那麽只要再這個區間進行二分即可
#include<stdio.h>
int a[100008];
int main()
{
    int n,m,i;
    int sum,maxn;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=sum=maxn=0;i<n;i++)
        {
            scanf("%d",a+i);
            sum+=a[i];
            maxn= maxn<a[i]?a[i]:maxn;
        }
        while(maxn<sum)
        {
            int num=1,sum1=0,mid=(maxn+sum)>>1;//等價於除二 
            for(i=0;i<n;i++)
            {
                sum1+=a[i];
                if(sum1>mid)
                {
                    sum1=a[i];
                    num++;
                }
            }
            if(num<=m)//fajomonth數 < M,即 mid太大,分少了 
               sum=mid;
            else
               maxn=mid+1;// 
        }
        printf("%d\n",maxn);
    } 
    return 0;
} 

poj 3273Monthly Expense Time Limit: 2000MS