1. 程式人生 > >What Kind of Friends Are You?(ZOJ)

What Kind of Friends Are You?(ZOJ)

                                     What Kind of Friends Are You?

Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar

, all the animals have become anthropomorphized into girls known as Friends.

Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends

along the way, and eventually discovers that she is a human.

However, Kaban soon finds that it's also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either "yes" or "no" to identitfy a kind of Friends.

To be more specific, there are n Friends

need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals' names that will give a "yes" answer to that question (and those animals who are not in the list will give a "no" answer to that question), so it's possible to determine the name of a Friends by combining the answers and the lists together.

But the work is too heavy for Kaban. Can you help her to finish it?

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T ≤ 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤ q ≤ 21), indicating the number of Friends need to be identified and the number of questions.

The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1, p2, ... , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.

For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1, si, 2, ... , si, mi (1 ≤ |si, j| ≤ 20), indicating the number of Friends and their names, who will give a "yes" answer to the i-th question. It's guaranteed that all the names appear in the known names of Friends.

For the following n lines, the i-th line contains q integers ai, 1, ai, 2, ... , ai, q (0 ≤ ai, j ≤ 1), indicating the answer (0 means "no", and 1 means "yes") to the j-th question given by the i-th Friends need to be identified.

It's guaranteed that all the names in the input consist of only uppercase and lowercase English letters.

Output

For each test case output n lines. If Kaban can determine the name of the i-th Friends need to be identified, print the name on the i-th line. Otherwise, print "Let's go to the library!!" (without quotes) on the i-th line instead.

Sample Input

2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1

Sample Output

Serval
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
B
Let's go to the library!!
K

Hint

The explanation for the first sample test case is given as follows:

As Serval is the only known animal who gives a "yes" answer to the 1st, 2nd and 4th question, and gives a "no" answer to the 3rd question, we output "Serval" (without quotes) on the first line.

As no animal is known to give a "no" answer to all the questions, we output "Let's go to the library!!" (without quotes) on the second line.

Both Alpaca and Moose give a "yes" answer to the 1st question, and a "no" answer to the 2nd, 3rd and 4th question. So we can't determine the name of the third Friends need to be identified, and output "Let's go to the library!!" (without quotes) on the third line.

題目連結:

https://vjudge.net/problem/ZOJ-3960

題意描述:

給定 n 個待確定名字的和 q 個問題。已知 c 個 的名字,對於第i個問題,有a個人回答yes,c-a個人回答no,現在有n個待確定的名字和q個為題的回答,如果能確定名字則輸出名字,否則輸出Let's go to the library!!

解題思路:

把問題回答yes的存到a數組裡並且賦值為1,建立一個二維矩陣,然後與輸入的矩陣進行比較,如果存在唯一相等的解,則能確定該人,否則不能確定。

程式程式碼:

#include<stdio.h>
#include<string.h>
int a[210][50],b[210][50];
char str[210][50],s[50];
int n,m,q;
int F(int *p);
int id(char *s);

int main()
{
	int T,i,j,k,c,count;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d%d",&n,&q,&m);
		for(i=0;i<m;i++)
			scanf(" %s",str[i]);
		memset(a,0,sizeof(a));
		scanf("%d",&c);
		for(i=0;i<q;i++)
		{
			scanf("%d",&c);
			for(j=0;j<c;j++)
			{
				scanf(" %s",s);
				a[id(s)][i]=1;
			}
		}
		for(i=0;i<n;i++)
			for(j=0;j<q;j++)
				scanf("%d",&b[i][j]);
		for(i=0;i<n;i++)
		{
			count=F(b[i]);
			if(count<0)
				printf("Let's go to the library!!\n");
			else
				printf("%s\n",str[count]);
					
		}
	}
}
int id(char *s)
{
	int i,j;
	for(i=0;i<m;i++) 
	{
		if(strcmp(s,str[i])==0)
			return i;
	}
	return 0;
}
int F(int *p)
{
	int i,j,x,count=0;
	for(i=0;i<m;i++) 
	{
		for(j=0;j<q;j++) 
			if(p[j]!=a[i][j])
				break;
		if(j==q)
		{
			x=i;
			count++;
		}
	}
	if(count==1)
		return x;
	return -1;
}