1. 程式人生 > >Hdu 3575 Hello Kiki 中國剩餘定理模板

Hdu 3575 Hello Kiki 中國剩餘定理模板

Problem Description

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "門前大橋下游過一群鴨,快來快來 數一數,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.

 

 

Input

The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

 

 

Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

 

 

Sample Input

 

2 2

14 57

5 56

5

19 54 40 24 80

11 2 36 20 76

 

 

Sample Output

 

Case 1: 341

Case 2: 5996

套用中國剩餘定理模板即可求解....

注意此題有特判, 當餘數為0時, 輸出最小公倍數.....

程式碼如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=55;
int t;
typedef __int64 ll;
ll m[maxn],a[maxn];
int k;
ll Extend (ll A,ll B,ll& X,ll& Y)
{
    if(B==0)
    {
        X=1; Y=0;
        return A;
    }
    else
    {
        ll ans,temp;
        ans=Extend (B,A%B,X,Y);
        temp=X;
        X=Y;
        Y=temp-A/B*Y;
        return ans;
    }
}
ll solve ()
{
    ll x,y,d,t,c;
    for (int i=1;i<k;i++)
    {
         c=a[i]-a[i-1];
         d=Extend (m[i-1],m[i],x,y);
         if(c%d) return -1;
         x=c/d*x;
         t=m[i]/d;
         x=(x%t+t)%t;
         a[i]=m[i-1]*x+a[i-1];
         m[i]=m[i]/d*m[i-1];
    }
    if(a[k-1]==0)
        a[k-1]=m[k-1];
    return a[k-1];
}
int main()
{
    scanf("%d",&t);
    for (int j=1;j<=t;j++)
    {
        scanf("%d",&k);
        for (int i=0;i<k;i++)
            scanf("%I64d",&m[i]);
        for (int i=0;i<k;i++)
            scanf("%I64d",&a[i]);
        ll ans=solve();
        printf("Case %d: %I64d\n",j,ans);
    }
    return 0;
}