1. 程式人生 > >Assign the task

Assign the task

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree. 

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one. 

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases. 

For each test case: 

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees. 

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N). 

The next line contains an integer M (M ≤ 50,000). 

The following M lines each contain a message which is either 

"C x" which means an inquiry for the current task of employee x 

or 

"T x y"which means the company assign task y to employee x. 

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3

Sample Output

Case #1:
-1 
1 
2
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include<vector>
using namespace std;
const int N=50000+10;
int t,n,m;
int ct=0;;
int tree[N<<2],lazy[N<<2];
int Start[N], End[N];
bool vis[N];
vector<int> work[N];
void init(){
    memset(tree,-1,sizeof(tree));
    memset(lazy,-1,sizeof(lazy));
    memset(vis,1,sizeof(vis));
}
void Pushdown(int rt ){
    if(lazy[rt]!=-1){
        tree[rt<<1|1]=tree[rt<<1]=lazy[rt<<1]=lazy[rt<<1|1]=lazy[rt];
        lazy[rt]=-1;

    }

}
void DFS(int n){
    Start[n]=++ct;
    int m = work[n].size();
    for(int i=0;i<m;i++){
        DFS(work[n][i]);
    }
    End[n]=ct;
}
void Build(int l,int r,int rt){
    if(l==r){
        tree[rt]=-1;
    }
    int m=(l+r)/2;
    Build(l,m,rt<<1);
    Build(m+1,r,rt<<1|1);
}
void Updata(int l,int r,int rt ,int L,int R,int C){
    if(L<=l&&r<=R){
        lazy[rt]=tree[rt]=C;
        return;
    }
    int m=(l+r)>>1;
    Pushdown(rt);
    if(L <= m) Updata(l,m,rt<<1,L,R,C);
    if(m < R) Updata(m+1,r,rt<<1|1,L,R,C);


}
int  Check(int l,int r,int rt ,int L){
    if(l==r){
        return tree[rt];
    }
    int m=(l+r)>>1;
    Pushdown(rt);
    if(L<=m)
        return Check(l,m,rt<<1,L);
    else
        return Check(m+1,r,rt<<1|1,L);


}
int main()
{
    scanf("%d",&t);
    for(int T=1;T<=t;T++){
        init();
        scanf("%d",&n);
        int u,v;
        ct=0;
        for(int i=1;i<=n;i++)
            work[i].clear();
        for(int i=1;i<n;i++){
            scanf("%d%d",&u,&v);

            work[v].push_back(u);
            vis[u]=0;
        }
        int pos = -1;
        for(int i = 1; i <= n; i++)
            if(vis[i]) {
                pos = i;
                break;
            }
        DFS(pos);//從最上級的人開始遞迴, 找到每個人對應的區間
        scanf("%d",&m);
        string c;
        int x,y;
        printf("Case #%d:\n",T);
        while(m--){
            cin>>c;
            if(c[0]=='T'){
                scanf("%d%d",&x,&y);
                Updata(1,ct,1 ,Start[x],End[x],y);

            }else{
                scanf("%d",&x);
                cout << Check(1,ct,1 ,Start[x]) << endl;
            }
        }

    }
    //cout << "Hello world!" << endl;
    return 0;
}