1. 程式人生 > >H - Antenna Placement (最小路徑覆蓋)

H - Antenna Placement (最小路徑覆蓋)

H - Antenna Placement

 

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.


Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?
 

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.
 

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

題意:

        求覆蓋 所有 ‘*’ 的最少天線個數。

思路:

        二分匹配 中 最小路徑覆蓋

       最小路徑覆蓋:

               取圖中的一些路徑,使之能覆蓋圖中所有頂點(本題關鍵),並且任何頂點有且只有一條路徑與之關聯。也就是說,如果把這些路徑中的每條路徑從它的起始點走到終點,那麼恰好可以經過圖中的頂點有且只有一次。

      最小路徑覆蓋與二分匹配的關係: 最小路徑覆蓋= 總頂點數-最大匹配數;(無向圖 記得 /2)

       摘自部落格:http://www.cnblogs.com/kuangbin/archive/2012/08/26/2657446.html

程式碼:

#include<map>
#include<queue>
#include<math.h>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define MM 507
int line[MM][MM],book[MM],man[MM],t[MM][MM];
char tu[MM][MM];
int n,m;
bool Find(int x)
{
    for(int i=1; i<=n; i++)
    {
        if(line[x][i] && !book[i])
        {
            book[i]=1;
            if(!man[i] || Find(man[i]))
            {
                man[i]=x;
                return true;
            }
        }
    }
    return false;
}
int match()
{
    int ans=0;
    for(int i=1; i<=n; i++)
    {
        mem(book,0);
        if(Find(i))
            ans++;
    }
    return ans/2;
}
int main()
{
    int ca;
    scanf("%d",&ca);
    while(ca--)
    {
        mem(tu,'o');
        mem(t,0);
        mem(line,0);
        mem(man,0);
        int tmp=0;
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
        {
            scanf("%s",tu[i]+1);
            for(int j=1; j<=m; j++)
            {
                if(tu[i][j]=='*')
                    t[i][j]=++tmp;
            }
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(tu[i][j]=='*')
                {
                    if(tu[i-1][j]=='*')
                        line[t[i][j]][t[i-1][j]]=1;
                    if(tu[i][j-1]=='*')
                        line[t[i][j]][t[i][j-1]]=1;
                    if(tu[i+1][j]=='*')
                        line[t[i][j]][t[i+1][j]]=1;
                    if(tu[i][j+1]=='*')
                        line[t[i][j]][t[i][j+1]]=1;
                }
            }
        }
        n=tmp;
        printf("%d\n",n-match());
    }
    return 0;
}