1. 程式人生 > >HDU 3974 Assign the task—— 線段樹樹狀儲存

HDU 3974 Assign the task—— 線段樹樹狀儲存

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole

company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

“C x” which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
Sample Input
1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3
Sample Output
Case #1:
-1
1
2

題意:

一家公司是以老闆—>員工—員工的員工這種方式存在的,一個老闆可以有多個員工,一旦某個人被分配到任務,他就會去做,並且他的員工會停下手上的任務去做。c x代表問這個人正在做啥,如果沒有輸出-1,T x y代表讓x去做y

題解:

dfs建樹,遞迴末尾記錄當前位置的最終兒子下標,之後就是普通線段樹了

#include<bits/stdc++.h>
using namespace std;
const int maxn=50005;
struct node
{
    int l,r;
}son[maxn];
int change[maxn];
int cnt=0;
int head[maxn];
int n,m;
struct edge
{
    int to,next;
}e[maxn];
void add(int x,int y)
{
    e[cnt].to=y;
    e[cnt].next=head[x];
    head[x]=cnt++;
}
int num;
void dfs(int fa)
{
    change[fa]=num;
    son[change[fa]].l=num;
    for(int i=head[fa];~i;i=e[i].next)
    {
        num++;
        dfs(e[i].to);
    }
    son[change[fa]].r=num;
}
int now[maxn<<2],flag[maxn<<2];
void pushdown(int root)
{
    if(flag[root]==-1)
        return ;
    now[root<<1]=flag[root];
    now[root<<1|1]=flag[root];
    flag[root<<1]=flag[root];
    flag[root<<1|1]=flag[root];
    flag[root]=-1;
}
void update(int l,int r,int root,int ql,int qr,int val)
{
    if(l>=ql&&r<=qr)
    {
        now[root]=val;
        flag[root]=val;
        return ;
    }
    pushdown(root);
    int mid=l+r>>1;
    if(mid>=ql)
        update(l,mid,root<<1,ql,qr,val);
    if(mid<qr)
        update(mid+1,r,root<<1|1,ql,qr,val);
}
int query(int l,int r,int root,int q)
{
    if(l==r)
        return now[root];
    pushdown(root);
    int mid=l+r>>1;
    if(mid>=q)
        return query(l,mid,root<<1,q);
    else
        return query(mid+1,r,root<<1|1,q);

}
int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        scanf("%d",&n);
        memset(head,-1,sizeof(head));
        cnt=0;
        int x,y;
        int fa[maxn];
        memset(fa,0,sizeof(fa));
        for(int i=1;i<n;i++)
            scanf("%d%d",&x,&y),add(y,x),fa[x]=1;
        num=1;
        for(int i=1;i<=n;i++)
            if(fa[i]==0)
                dfs(i);
        memset(now,-1,sizeof(now));
        memset(flag,-1,sizeof(flag));
        scanf("%d",&m);
        printf("Case #%d:\n",++cas);
        char s[2];
        int pos,val;
        while(m--)
        {
            scanf("%s",s);
            if(s[0]=='T')
            {
                scanf("%d%d",&pos,&val);
                pos=change[pos];
                int l=son[pos].l,r=son[pos].r;
                update(1,n,1,l,r,val);
            }
            else
            {
                scanf("%d",&pos);
                pos=change[pos];
                printf("%d\n",query(1,n,1,pos));
            }
        }
    }
    return 0;
}