1. 程式人生 > >C - Crusaders Quest (棧和佇列的運用)

C - Crusaders Quest (棧和佇列的運用)

滴答滴答---題目連結 

Crusaders Quest is an interesting mobile game. A mysterious witch has brought great darkness to the game world, and the only hope for your kingdom is to save the Goddesses so that they can unleash their power to fight against the witch.

 

 

In order to save the game world, you need to choose three heroes to fight for victory and use their skills wisely. Nine skill blocks of three different types (three blocks per type) will be presented at the bottom of the screen. If  () consecutive blocks are of the same type, you can tap on them and eliminate them, thus triggering the powerful skill they represent. After the elimination, the blocks to their left will be connected with the blocks to their right. Moreover, if  consecutive blocks of the same type are eliminated, the powerful skill they unleash will be upgraded to a super skill, which is the most powerful skill of all.

DreamGrid is a newbie in this game, and he wants to trigger the super skill as many times as he can. Given nine skill blocks satisfying the description above, please help DreamGrid calculate the maximum number of times he can trigger the super skill.

Input

There are multiple test cases. The first line of input contains an integer  (about 50), indicating the number of test cases. For each test case:

The first line contains a string  () consisting of three 'g's, three 'a's and three 'o's, representing the nine skill blocks of three different types. Each type of character represents one type of skill block.

Output

For each test case, output an integer denoting the maximum number of times DreamGrid can trigger the super skill.

Sample Input

7
gggaaaooo
aaoogggoa
googgaaao
agogaooag
goooggaaa
gogogoaaa
gaogaogao

Sample Output

3
3
2
1
3
2
1

Hint

For the first sample test case, DreamGrid can first eliminate "aaa" (one super skill triggered), thus changing the skill blocks to "gggooo". He can then eliminate "ggg" (another super skill triggered) and finally eliminate "ooo" (a third super skill triggered). So the answer is 3.

For the second sample test case, DreamGrid can first eliminate "ggg" (one super skill triggered), thus changing the skill blocks to "aaoooa". He can then eliminate "ooo" (another super skill triggered) and finally eliminate "aaa" (a third super skill triggered). So the answer is also 3.

For the third sample test case, DreamGrid can first eliminate "aaa" (one super skill triggered), thus changing the skill blocks to "googgo". He can then eliminate "oo" to obtain "gggo", and eliminate "ggg" (another super skill triggered) to obtain "o". So the answer is 2. It is easy to prove that he cannot trigger the super skill three times under this arrangement of skill blocks.

#include <iostream>
#include<string.h>
#include<stdio.h>
#include<stack>
#include<algorithm>
using namespace std;
int num;
int f(char *s)
{
    char a,b;
    stack<char>q;
    int  n=strlen(s);
    for(int i=0; i<n; i++)
    {
        if(q.size()>=2)
        {
            a=q.top();
            q.pop();
            b=q.top();
            q.pop();
            if(a==b&&b==s[i])
                num++;
            else
            {
                q.push(b);
                q.push(a);
                q.push(s[i]);
            }
        }
        else
            q.push(s[i]);
    }
    if(!q.empty())
        return 0;
    else return 1;
}
int main()
{
    char s[15],s2[15];
    int t,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s);
        num=0;
        if(f(s)==1)
        {
            printf("%d\n",num);
            continue;
        }
        if(num==1)
        {
            printf("%d\n",num+1);
            continue;
        }
        num=j=0;
        for(int i=0; i<9; i++)
            if(s[i]!='a')
                s2[j++]=s[i];
        s2[j]='\0';
        if(f(s2)==1)
        {
            printf("2\n");
            continue;
        }
        num=j=0;
        for(int i=0; i<9; i++)
            if(s[i]!='g')
                s2[j++]=s[i];
        s2[j]='\0';
        if(f(s2)==1)
        {
            printf("2\n");
            continue;
        }
        num=j=0;
        for(int i=0; i<9; i++)
            if(s[i]!='o')
                s2[j++]=s[i];
        s2[j]='\0';
        if(f(s2)==1)
        {
            printf("2\n");
            continue;
        }
        printf("1\n");
    }

    return 0;
}