1. 程式人生 > >HDU1151:Air Raid(最小邊覆蓋)

HDU1151:Air Raid(最小邊覆蓋)

spec p s aid equal font targe accept ace sta

Air Raid

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6528 Accepted Submission(s): 4330

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1151

Description:

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town‘s streets you can never reach the same intersection i.e. the town‘s streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input:

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town‘s streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output:

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input:

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output:

2
1

題意:

最少需要多少個跳傘兵,可以到達所有的點,如果點已經被別的傘兵到達過,則不再被重復到達。

題解:

最小邊覆蓋模板題。

最小邊覆蓋指的就是最少多少邊可以把所有點相連接(每個點一條邊與之相連),求法就是連邊時構造一個x‘集合,將x集合與x‘集合中的元素相連。最終的答案就是點的總數減去最大匹配數。

證明方法可以參考《訓練指南》,大致意思就是:最小邊覆蓋<=>最少結尾點<=>最多非結尾點<=>二分圖最大匹配。這裏的結尾點指的就是簡單匹配中最後的那個結點。

這題還有個進階版:http://poj.org/problem?id=2594

代碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define mem(x) memset(x,0,sizeof(x))
using namespace std;

const int N = 510 ;
int n,t,m,ans;
int check[N],match[N],map[N][N];

inline int dfs(int x){
    for(int i=n+1;i<=2*n;i++){
        if(map[x][i] && !check[i]){
            check[i]=1;
            if(!match[i] || dfs(match[i])){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        mem(map);mem(match);ans=0;
        for(int i=1,x,y;i<=m;i++){
            scanf("%d%d",&x,&y);
            map[x][y+n]=1;
        }
        for(int i=1;i<=n;i++){
            mem(check);
            if(dfs(i)) ans++;
        }
        printf("%d\n",n-ans);
    }
    return 0;
}

HDU1151:Air Raid(最小邊覆蓋)