1. 程式人生 > >Savings Account(水題)

Savings Account(水題)

Suppose you open a savings account with a certain initial balance. You will not make any withdrawals or further deposits for a number of years. The bank will compound your balance (add the annual interest) once a year, on the anniversary of the opening of the account. Your goal is to achieve a certain target amount in your savings account. In how may years will the target amount be achieved?
Input
The input file will contain data for one or more test cases, one test case per line. Each line will contain three numbers: the initial balance, the annual interest rate (as a percentage of the balance), and the target amount, separated by blank spaces. These will be positive numbers; they may or may not contain a decimal point. The target amount will be greater than the initial balance. The input is terminated by end-of-file
Output
For each line of input, your program will produce exactly one line of output: This line will contain one positive integer value: the number of years required to achieve the target amount.
Sample Input
200.00 6.5 300
500 4 1000.00
Sample Output
7
18
就是銀行的存款機制,水題一發,但是注意精度問題。
程式碼如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;

double n,p,m;

int main()
{
	while(scanf("%lf%lf%lf",&n,&p,&m)!=EOF)
	{
		int cnt=0;
		while(n<m)
		{
			n=(1+p/100)*n;
			cnt++;
		}
		printf("%d\n",cnt);
	}
}

努力加油a啊,(o)/~