1. 程式人生 > >zoj 3261Connections in Galaxy War(並查集加離線處理)

zoj 3261Connections in Galaxy War(並查集加離線處理)

n order to strengthen the defense ability, many stars in galaxy allied together and built many bidirectional tunnels to exchange messages. However, when the Galaxy War began, some tunnels were destroyed by the monsters from another dimension. Then many problems were raised when some of the stars wanted to seek help from the others.

In the galaxy, the stars are numbered from 0 to N-1 and their power was marked by a non-negative integer pi. When the star A wanted to seek help, it would send the message to the star with the largest power which was connected with star A directly or indirectly. In addition, this star should be more powerful than the star A

. If there were more than one star which had the same largest power, then the one with the smallest serial number was chosen. And therefore, sometimes star A couldn't find such star for help.

Given the information of the war and the queries about some particular stars, for each query, please find out whether this star could seek another star for help and which star should be chosen.

Input

There are no more than 20 cases. Process to the end of file.

For each cases, the first line contains an integer N (1 <= N <= 10000), which is the number of stars. The second line contains N integers p0p1, ... , pn-1 (0 <= pi <= 1000000000), representing the power of the i-th star. Then the third line is a single integer M (0 <= M <= 20000), that is the number of tunnels built before the war. Then M lines follows. Each line has two integers ab (0 <= ab <= N - 1, a != b), which means star a and star b has a connection tunnel. It's guaranteed that each connection will only be described once.

In the (M + 2)-th line is an integer Q (0 <= Q <= 50000) which is the number of the information and queries. In the following Q lines, each line will be written in one of next two formats.

"destroy a b" - the connection between star a and star b was destroyed by the monsters. It's guaranteed that the connection between star a and star b was available before the monsters' attack.

"query a" - star a wanted to know which star it should turn to for help

There is a blank line between consecutive cases.

Output

For each query in the input, if there is no star that star a can turn to for help, then output "-1"; otherwise, output the serial number of the chosen star.

Print a blank line between consecutive cases.

Sample Input

2
10 20
1
0 1
5
query 0
query 1
destroy 0 1
query 0
query 1

Sample Output

1
-1
-1
-1

在合併時考慮合併條件,power大的做根節點,如果相同,遍號小的做根節點,然後離線處理處所有點以及所有邊,以及各條命令,這裡可以用map來代替二維陣列,然後就可以用並查集反向操作了,因為並查集相當於加邊,要刪除應該反向,如果是破壞就刪除,如果是查詢就找到對應根節點,這裡還得進行判斷

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#define maxn 10005
int father[maxn];
int v[maxn];
using namespace std;
int find(int x)
{
    if(father[x]!=x)
    father[x]=find(father[x]);
    return father[x];

}
void unionn(int x,int y)
{
    int r1=find(x);
    int r2=find(y);
    if(r1!=r2)
    {
        if(v[r1]==v[r2])
        {
            if(r1<r2)
            father[r2]=r1;
            else if(r2<r1)
            father[r1]=r2;
        }
        else if(v[r1]!=v[r2])
        {
            if(v[r1]<v[r2])
            father[r1]=r2;
            else if(v[r1]>v[r2])
            father[r2]=r1;
        }
    }
}
struct command
{
    int type;
    int u,v;

}coms[50010];
struct edge
{
    int u,v;
}edge[20010];
map<int,int>mp[maxn];
bool vis[20010];
int main()
{int n,m;
bool first=true;
while(~scanf("%d",&n))
{
    if(first)
    first=false;
    else
    printf("\n");
    for(int i=0;i<=maxn;i++)
    father[i]=i;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&v[i]);
        mp[i].clear();
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++)
    {int u,v;
        vis[i]=true;
        scanf("%d%d",&u,&v);
        if(u>v)
        swap(u,v);
        edge[i].u=u;
        edge[i].v=v;
        mp[u][v]=i;
    }
    int q;
    scanf("%d",&q);
    for(int i=0;i<q;i++)
    {
        char str[20];
        scanf("%s",&str);
        if(str[0]=='q')
        {int u;
            coms[i].type=0;
            scanf("%d",&coms[i].u);

        }
        else if(str[0]=='d')
        {coms[i].type=1;
        int u,v;
        scanf("%d%d",&u,&v);
        if(u>v)
        swap(u,v);
        coms[i].u=u;
        coms[i].v=v;
        vis[mp[u][v]]=false;


        }
    }
    for(int i=0;i<m;i++)
    {if (vis[i])
        {int u=edge[i].u;
        int v=edge[i].v;
        unionn(u,v);


    }

}
int tot=0;
int ans[50010];
for(int i=q-1;i>=0;i--)
{
    if(coms[i].type==0)
    {
        int fa=find(coms[i].u);
        if(fa!=coms[i].u&&v[fa]>v[coms[i].u])
        ans[tot]=fa;
        else
        ans[tot]=-1;
        tot++;
    }
    else if(coms[i].type==1)
    unionn(coms[i].u,coms[i].v);
}
for(int i=tot-1;i>=0;i--)
printf("%d\n",ans[i]);
}
return 0;
}