1. 程式人生 > >POJ2594:Treasure Exploration(Floyd + 最小路徑覆蓋)

POJ2594:Treasure Exploration(Floyd + 最小路徑覆蓋)

body bsp sent space p s form desc after floyd

Treasure Exploration

Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 9794 Accepted: 3975

題目鏈接:http://poj.org/problem?id=2594

Description:

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input:

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output:

For each test of the input, print a line containing the least robots needed.

Sample Input:

1 0
2 1
1 2
2 0
0 0

Sample Output:

1
1
2

題意

問有向圖裏,需要最少多少個機器人,能走遍所有的點,並且可以走其它機器人已經走過的路徑。

題解:

這道題我一開始以為就是最小路徑覆蓋,結果一直WA...

但其實這題和最小路徑覆蓋有區別,最小路徑覆蓋的要求就是在圖中找盡量少的路徑,讓每個節點恰好在一條路徑上,單獨的一個結點也可以作為一條路徑。但是,正是因為每個結點在一條路徑上,所以沒有重復的路徑。

但是這題路徑是可以重復的,所以可以利用floyd傳遞閉包,讓原來被“阻斷”的路徑可以鏈接起來。

推薦一下這篇博客,挺好的,講的挺詳細的:https://www.cnblogs.com/justPassBy/p/5369930.html

代碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#define mem(x) memset(x,0,sizeof(x))
using namespace std;

const int N = 505 ;
int map[N][N],check[N<<1],match[N<<1],link[N][N<<1];
int n,m,ans;

inline int dfs(int x){
    for(int i=n+1;i<=2*n;i++){
        if(link[x][i] && !check[i]){
            check[i]=1;
            if(!match[i] || dfs(match[i])){
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main(){
    while(scanf("%d%d",&n,&m)){
        if(!n && !m) break ;
        mem(map);mem(match);mem(link);ans=0;
        for(int i=1,x,y;i<=m;i++){
            scanf("%d%d",&x,&y);
            map[x][y]=1;
        }
        for(int k=1;k<=n;k++){
            for(int i=1;i<=n;i++){
                if(map[i][k])
                for(int j=1;j<=n;j++){
                    if(map[k][j]) map[i][j]=1;
                }
            }
        }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(map[i][j]) link[i][j+n]=1;
        for(int i=1;i<=n;i++){
            mem(check);
            if(dfs(i)) ans++;
        }
        printf("%d\n",n-ans);
    }    
    return 0;
} 

POJ2594:Treasure Exploration(Floyd + 最小路徑覆蓋)