1. 程式人生 > >線段樹-----F - Count the Colors

線段樹-----F - Count the Colors

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.
Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.
Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.
If some color can’t be seen, you shouldn’t print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1
1 1

0 2
1 1

涉及到區間覆蓋,區間染色,基本可以用線段樹解決,其實模擬直接做就行,因為10^6不會超,用線段樹就會快很多。。。
先將每個區間賦予顏色,然後再找顏色段

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 8000 + 5;

int tree[N << 2];
int num[N];
int res[N];
int k;

void pushdown(int root)
{
    if(tree[root] != -1){
        tree[root * 2 + 1] = tree[root];
        tree[root * 2 + 2] = tree[root];
        tree[root] = -1;
    }
}

void update(int root,int l,int r,int pl,int pr,int val)
{
    if(r < pl || l > pr){
        return ;
    }
    if(l >= pl && r <= pr){
        tree[root] = val;
        return ;
    }
    pushdown(root);
    int mid = (l + r) / 2;
    if(pl <= mid){
        update(root * 2 + 1,l,mid,pl,pr,val);
    }
    if(pr > mid){
        update(root * 2 + 2,mid + 1,r,pl,pr,val);
    }
}

void query(int root,int l,int r,int pl,int pr)
{
    if(l == r){
        res[k++] = tree[root];
        return ;
    }
    pushdown(root);
    int mid = (l + r) / 2;
    if(pl <= mid){
        query(root * 2 + 1,l,mid,pl,pr);
    }
    if(pr > mid){
        query(root * 2 + 2,mid + 1,r,pl,pr);
    }
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(tree,-1,sizeof(tree));
        memset(res,-1,sizeof(res));
        memset(num,0,sizeof(num));
        for(int i = 0;i < n;++i){
            int x,y,z;
            scanf("%d %d %d",&x,&y,&z);
            update(1,1,8000,x + 1,y,z);
        }
        k = 0;
        query(1,1,8000,1,8000);
        for(int i = 0;i < k;)
        {
            if(res[i] == -1){
                i++;
                continue;
            }
            num[res[i]]++;
            int j;
            for(j = i + 1;j < k;++j){
                if(res[j] != res[i] || res[j] == -1){
                    break;
                }
            }
            i = j;
        }
        for(int i = 0;i <= 8000;++i){
            if(num[i] != 0){
                printf("%d %d\n",i,num[i]);
            }
        }
        printf("\n");
    }
    return 0;
}