1. 程式人生 > >HDU2844 Coins【多重揹包】

HDU2844 Coins【多重揹包】

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20670    Accepted Submission(s): 8121


 

Problem Description

Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

Source

2009 Multi-University Training Contest 3 - Host by WHU

問題連結:HDU2844 Coins

問題描述:有n種硬幣,價值為A1 A2 A3...An 數量分別為C1 C2 C3...Cn。問能用這些硬幣表示多少種在1~m範圍內的價值

解題思路:多重揹包。初始化時要用負數初始化dp,具體看程式。

AC的C++程式:

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

const int N=100010;
const int INF=1000000;
int dp[N],a[N],c[N];
int n,m;

//01揹包 
void ZeroOnePack(int cost,int weight)
{
	for(int v=m;v>=cost;v--)
	  dp[v]=max(dp[v],dp[v-cost]+weight); 
}

//完全揹包
void CompletePack(int cost,int weight)
{
	for(int v=cost;v<=m;v++)
	  dp[v]=max(dp[v],dp[v-cost]+weight);
}

//多重揹包
void MultiplePack(int cost,int weight,int amount)
{
	if(cost*amount>=m)
	  CompletePack(cost,weight);
	else{
		int k=1,num=amount;
		while(2*k<=num){
			ZeroOnePack(k*cost,k*weight);
			amount-=k;
			k*=2;
		}
		ZeroOnePack(amount*cost,amount*weight);
	}
} 

int main()
{
	while(~scanf("%d%d",&n,&m)&&(n||m)){
		for(int i=0;i<n;i++)
		  scanf("%d",&a[i]);
		for(int i=0;i<n;i++)
		  scanf("%d",&c[i]);
		memset(dp,-INF,sizeof(dp));
		dp[0]=0;
		for(int i=0;i<n;i++)
		  MultiplePack(a[i],a[i],c[i]);
		int ans=0;
		for(int i=1;i<=m;i++)
		  if(dp[i]>0)
		    ans++;
		printf("%d\n",ans);
	}
	return 0;
}