1. 程式人生 > >【POJ 2318】TOYS

【POJ 2318】TOYS

【題目】

傳送門

Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

在這裡插入圖片描述

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.

【分析】

大致題意:給出一個箱子,裡面有 n n 個隔板,現在給出 m m 個玩具的座標,問每塊區域內玩具的個數

題解:計算幾何+二分

其實這道題也不是一道難題,由於題目中說了給出的隔板是有序的,滿足單調性,所以我們對於每個玩具,就二分找出它應該剛好在哪一塊隔板的左邊(或右邊都可以),找的時候也比較簡單,就直接利用叉積的性質,找到後統計答案即可

注意一下輸出格式,其中最後一個詢問結束後應只輸出一個換行,不能輸出兩個

【程式碼】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 5005
#define eps 1e-8
using namespace std;
int n,m,x1,y1,x2,y2;
int u[N],l[N],num[N];
struct point
{
	int x,y;
	point(){}
	point(int x,int y):x(x),y(y){}
	point operator+(const point &a)  {return point(x+a.x,y+a.y);}
	point operator-(const point &a)  {return point(x-a.x,y-a.y);}
	point operator*(const int &a)  {return point(x*a,y*a);}
	point operator/(const int &a)  {return point(x/a,y/a);}
	friend int dot(const point &a,const point &b)  {return a.x*b.x+a.y*b.y;}
	friend int cross(const point &a,const point &b)  {return a.x*b.y-a.y*b.x;}
}p;
bool check(int mid)
{
	point a=point(u[mid],y1);
	point b=point(l[mid],y2);
	return cross(a-p,b-p)<=0;
}
int solve()
{
	int l=1,r=n+1;
	while(l<r)
	{
		int mid=(l+r)>>1;
		if(check(mid))  r=mid;
		else  l=mid+1;
	}
	return l-1;
}
int main()
{
	int i,cas=0;
	while(~scanf("%d",&n))
	{
		if(!n)  break;
		scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
		for(i=1;i<=n;++i)
		  scanf("%d%d",&u[i],&l[i]);
		u[n+1]=l[n+1]=x2;
		memset(num,0,sizeof(num));
		for(i=1;i<=m;++i)
		{
			scanf("%d%d",&p.x,&p.y);
			num[solve()]++;
		}
		if(++cas!=1)  printf("\n");
		for(i=0;i<=n;++i)
		  printf("%d: %d\n",i,num[i]);
	}
	return 0;
}