1. 程式人生 > >POJ2411:Mondriaan's Dream(狀壓DP)

POJ2411:Mondriaan's Dream(狀壓DP)

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

程式碼:

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;
__int64 dp[12][1<<12],temp;
int n,m;
void dfs(int i,int state,int k)///第i行,狀態數,第k列
{
    if(k>=m)
    {
        dp[i][state]+=temp;
        return;
    }
    dfs(i,state,k+1);
    if(k<=m-2&&!(state&1<<k)&&!(state&1<<k+1))///判斷第K+1,k+2位是否為0,可否橫放
    {
        dfs(i,state|1<<k|1<<k+1,k+2);
    }

}
int main()
{
    int i,j;

    while(scanf("%d%d",&n,&m),n+m)
    {
        temp=1;
        memset(dp,0,sizeof(dp));
        temp=1;
        dfs(1,0,0);
        for(i=2;i<=n;i++)
        {
            for( j=0;j<(1<<m);j++)
            {
               if(dp[i-1][j])
               {
                   temp=dp[i-1][j];///掃描i行上可能橫放的所有可能,累加到i-1行上面

               }
               else continue;
               dfs(i,~j&((1<<m)-1),0);///如果上一層有沒有橫放的,必須在下一層豎放一個塊
            }

        }
        printf("%I64d\n",dp[n][(1<<m)-1]);
    }
    return 0;
}