1. 程式人生 > >1048 Find Coins (25 分)(二分或雜湊)

1048 Find Coins (25 分)(二分或雜湊)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​(separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output No Solution

 instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution
#include<bits/stdc++.h>
using namespace std;
/*二分
int main(){
    int n,m;
    cin>>n>>m;
    int val[100005];
    for(int i = 0 ; i < n ; i++)
    {
        scanf("%d",&val[i]);
    }
    sort(val,val+n);
    for(int i = 0 ;i<n;i++)
    {
        int st = i+1,ed=n;
        while(st<ed)
        {
            int mid = (st+ed)/2;
            if(val[mid]>m){
                ed = mid;
                continue;
            }
            if(val[i]+val[mid]>m)ed = mid;
            else if(val[i]+val[mid]==m){
                printf("%d %d\n",val[i],val[mid]);
                return 0;
            }
            else st = mid +1;
        }
        if(val[i]>m)break;
    }
    return 0;

}*/
int HashTable[1005];
int main(){
    int n,m,a;
    scanf("%d %d",&n,&m);
    for(int i = 0 ; i < n ; i++)
    {
        scanf("%d",&a);
        HashTable[a]++;
    }
    for(int i = 1; i < m ;i++)
    {
        if(HashTable[i]&&HashTable[m-i]){
            if(i==m-i&&HashTable[i]<=1){
                continue;
            }
            printf("%d %d",i,m-i);
            return 0;
        }
    }
    printf("No Solution\n");
    return 0;
}