1. 程式人生 > >POJ-2492-A Bug's Life(並查集分類)

POJ-2492-A Bug's Life(並查集分類)


Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!


思路:把性別不同的的放在不同集合裡,如果出現已經存在,並且和一起輸進來的節點同性,則可以斷定出現異常蟲。

技巧:二倍節點,從而實現集合分類。

坑點:這個題要壓縮並查集,將所有節點直接指向編號節點,否則會TE。


#include<cstdio>
using namespace std;
int n,m;
int bin[4010];

//這樣寫find會超時 
//int find(int x){
//    while(bin[x]!=x)
//        x=bin[x];
//    return x;    
//}

int find(int x) 
{
    if(bin[x] == x)
        return bin[x];
    return bin[x] = find(bin[x]);
}
void merge(int x,int y){
    int fx,fy;
    fx=find(x);
    fy=find(y);
    if(bin[fx]!=bin[fy])
        bin[fx]=fy;
}

bool same(int x,int y){
    return find(x)==find(y);
}

int main(){
    int t ;
    scanf("%d",&t);
    for(int p=1;p<=t;p++){
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n*2;i++)
            bin[i]=i;
        int flag=0;        
        while(m--){
            int x,y;
            scanf("%d%d",&x,&y);
                        
            if(same(x,y)||same(x+n,y+n)) flag=1;
            if(flag) break;    
            merge(x,y+n);
            merge(x+n,y);
        }
        printf("Scenario #%d:\n",p);
        if(flag)
            printf("Suspicious bugs found!\n\n");
        else 
            printf("No suspicious bugs found!\n\n");
        
    }
    return 0;
}