1. 程式人生 > >"巴卡斯杯" 中國大學生程式設計競賽 - 女生專場 B - Desert

"巴卡斯杯" 中國大學生程式設計競賽 - 女生專場 B - Desert

A tourist gets lost in the desert with n liters of water. He drinks positive integer units of water each day. 

Write a program to calculate how many different ways the tourist can drink up the water. 

Input

The first line contains the number of test cases T(T≤10)T(T≤10). 
Next TT lines contain the number n(1≤n≤1000000)n(1≤n≤1000000) for each test case. 

Output

Output consists of TT lines. 
Each line contains the binary number which represents number of different ways to finish up the water specified in the test case. 

Sample Input

1
3

Sample Output

100


        
  

Hint

3 liters of water can be comsumed in four different ways show in the following.  
1. 1 1 1  
2. 1 2  
3. 2 1  
4. 3  

If we write 4 in binary, it's 100.
#include<iostream>
using namespace std;


int main()
{
	int n,m,j,k,i,T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		printf("1");
		for (i=1;i<=n-1;i++)
		printf("0");
		printf("\n");
	}
	
	return 0;
 }