1. 程式人生 > >Hdoj 2199.Can you solve this equation? 題解

Hdoj 2199.Can you solve this equation? 題解

Problem Description

Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

Author

Redow


思路

這個問題可以用二分法解決,因為給定的函式是單調的,所以可以根據要求的精度不斷二分找答案

詳見程式碼

程式碼

#include<bits/stdc++.h>
using namespace std;

double f(double x)
{
    return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6 ;
}
    
int main() 
{
    int n;
    cin >> n;
    while(n--)
    {
        double t;
        cin >> t;
        double l = 0, r = 100.0;
        if(t<f(0) || t>f(100.0))
        {
            cout << "No solution!\n";
            continue;
        }//因為函式單調,所以可以這麼判斷
        double mid; 
        while(r-l>1e-8)
        {
            mid = (l+r)/2;
            double ans = f(mid);
            if(ans>t)
                r = mid;
            if(ans<t)
                l = mid;
        }
        printf("%.4lf\n",l);
    }
    return 0;
}