1. 程式人生 > >【2017 ICPC亞洲區域賽北京站 J】Pangu and Stones(區間dp)

【2017 ICPC亞洲區域賽北京站 J】Pangu and Stones(區間dp)

In Chinese mythology, Pangu is the first living being and the creator of the sky and the earth. He woke up from an egg and split the egg into two parts: the sky and the earth.

At the beginning, there was no mountain on the earth, only stones all over the land.

There were N piles of stones, numbered from 1 to N. Pangu wanted to merge all of them into one pile to build a great mountain. If the sum of stones of some piles was S, Pangu would need S seconds to pile them into one pile, and there would be S stones in the new pile.

Unfortunately, every time Pangu could only merge successive piles into one pile. And the number of piles he merged shouldn't be less than L or greater than R.

Pangu wanted to finish this as soon as possible.

Can you help him? If there was no solution, you should answer '0'.

Input

There are multiple test cases.

The first line of each case contains three integers N,L,R as above mentioned (2<=N<=100,2<=L<=R<=N).

The second line of each case contains N integers a1,a2 …aN (1<= ai  <=1000,i= 1…N ), indicating the number of stones of  pile 1, pile 2 …pile N.

The number of test cases is less than 110 and there are at most 5 test cases in which N >= 50.

Output

For each test case, you should output the minimum time(in seconds) Pangu had to take . If it was impossible for Pangu to do his job, you should output  0.

Sample Input

3 2 2
1 2 3
3 2 3
1 2 3
4 3 3
1 2 3 4

Sample Output

9
6
0

題意:

n個石子堆排成一排,每次可以將連續的[L,R]堆石子合併成一堆,花費為要合併的石子總數。求將所有石子合併成一堆的最小花費,如無法實現則輸出0。

思路:

dp[i][j][k]表示區間[i, j]分成k堆的最小代價,轉移有

k=1時:

dp[i][j][1]=min(dp[i][j][1],dp[i][j][q]+sum[j]-sum[i-1]) 

k>1時:

dp[i][j][q]=min(dp[i][j][q],dp[i][k][q-1]+dp[k+1][j][1]) 

#include<bits/stdc++.h> 
using namespace std;
#define MAX 105
#define INF 0x3f3f3f3f
int sum[MAX],dp[MAX][MAX][MAX];
int main()
{
    int n,l,r,i,j,k;
    while(scanf("%d%d%d",&n,&l,&r)!=EOF)
    {
        memset(dp,INF,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&sum[i]);
            dp[i][i][1]=0;
            sum[i]+=sum[i-1];
        }
        int len;
        for(len=l;len<=r;len++)    //merge長度 len[l,r] 
        {
            for(i=1;i+len-1<=n;i++)//merge範圍 [i,i+len-1]
            {
                j=i+len-1;
                dp[i][j][len]=0;
                dp[i][j][1]=sum[j]-sum[i-1];
            }
        }
    
        int q;
        for(len=2;len<=n;len++)    //merge長度 len[2,n] 
        {
            for(i=1;i+len-1<=n;i++)//merge範圍 [i,i+len-1]
            {
                j=i+len-1;
                for(k=i;k<j;k++)
                    for(q=2;q<=len;q++)
                        dp[i][j][q]=min(dp[i][j][q],dp[i][k][q-1]+dp[k+1][j][1]);
                for(q=l;q<=r;q++)
                    dp[i][j][1]=min(dp[i][j][1],dp[i][j][q]+sum[j]-sum[i-1]);
            } 
        }
    
        if(dp[1][n][1]<INF)
            printf("%d\n",dp[1][n][1]);
        else printf("0\n");
    }
    return 0;
}