1. 程式人生 > >POJ2236:Wireless Network(並查集)

POJ2236:Wireless Network(並查集)

檢查 dia 以及 ring answer getchar() memory tween coord

Wireless Network

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 39772 Accepted: 16479

題目鏈接:http://poj.org/problem?id=2236

Description:

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input:

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output:

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input:

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output:

FAIL
SUCCESS

題意:

給定n臺電腦的位置以及一個距離d,有兩個操作:修復以及檢查是否連通。當電腦之間的距離小於d時則為連通,電腦也可以被作為其它電腦連通的中轉站。

題解:

註意這題的time limit是10s...我一開始沒註意這個想半天都沒想出來。。。

當發現這是10s後就好解決了,修復的時候將可以連通的放在一個集合裏,然後詢問的時候查詢一下就好了。

代碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;

const int N = 1005;
int n,d;
int f[N],vis[N];
struct node{
    int x,y;
}a[N];

bool dist(node A,node B){
    int tmp1 = A.x-B.x,tmp2 = A.y-B.y;
    return tmp1*tmp1+tmp2*tmp2<=d*d;
}

int find(int x){return x==f[x] ? x : f[x]=find(f[x]);}

int main(){
    scanf("%d%d",&n,&d);
    for(int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
    for(int i=1;i<=n+1;i++) f[i]=i;
    getchar();char c;
    while(scanf("%c",&c)!=EOF){
        if(c==O){
            int p;scanf("%d",&p);
            vis[p]=1;
            for(int i=1;i<=n;i++){
                if(i==p) continue ;
                if(vis[i] && dist(a[p],a[i])){
                    int fp=find(p),fi=find(i);
                    f[fp]=fi;
                }
            }
        }else{
            int p1,p2;scanf("%d%d",&p1,&p2);
            int f1=find(p1),f2=find(p2);
            if(f1==f2){
                puts("SUCCESS");
            }else puts("FAIL");
        }
        getchar();
    }
    return 0;
}

POJ2236:Wireless Network(並查集)