1. 程式人生 > >POJ - 1463 Strategic game 樹形dp

POJ - 1463 Strategic game 樹形dp

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:


  • the number of nodes
  • the description of each node in the following format
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads
    or
    node_identifier:(0)


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

題解:如果一個點上放士兵,那士兵相鄰位置的路都會被看守住,現在問如果要把所有路都看守住,至少需要放多少士兵。

題解:這算是一個樹形dp的模板題了吧,dp[u][1] 代表選u這個點  dp[u][0] 代表不選u這個點

dp[u][1] += min(dp[son][0],dp[son][1])                 dp[u][0] += dp[son][1]        

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int N = 1500 + 10;
vector<int> v[N];
int n;
int dp[N][2], in[N];
void dfs(int u) {
	dp[u][0] = 0;
	dp[u][1] = 1;
//	cout << u << endl;
	for(int i = 0; i < v[u].size(); ++i) {
		int to = v[u][i];
		dfs(to);
		dp[u][1] += min(dp[to][0],dp[to][1]);
		dp[u][0] += dp[to][1];
	}
}
int main() {
	int num, id, to;
	while(~scanf("%d", &n)) {
		for(int i = 0; i < n; ++i ) in[i] = 0, v[i].clear();
		for(int i = 0; i < n; ++i) {
			scanf("%d:(%d)", &id, &num);
			while(num--) {
				scanf("%d", &to);
				in[to]++;
				v[id].push_back(to);
			}
		}
		for(int i = 0;i < n; ++i) {
			if(in[i] == 0) {
				dfs(i);
				id = i;
				break;
			}
		}
		printf("%d\n", min(dp[id][0], dp[id][1]));
	}
	return 0;
}