1. 程式人生 > >PAT (Advanced Level) Practice 1118 Birds in Forest (25 分) 並查集

PAT (Advanced Level) Practice 1118 Birds in Forest (25 分) 並查集

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​'s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.

After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes

if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

題意:
給出n個集合,每個集合中有k只鳥,求總共的集合數目和小鳥的數目。

判斷兩隻鳥是否在一個集合中。

 程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
const int maxn=1e4+5;
int n,k,q;
int num=0;
int a[maxn];
int b[maxn];
map<int,int>ma;
int Find(int x)
{
    if(a[x]==x)
    {
        return x;
    }
    return a[x]=Find(a[x]);
}
void unit(int x,int y)
{
    int parx=Find(x);
    int pary=Find(y);
    if(parx!=pary)
        a[parx]=pary;
}
int main()
{
    scanf("%d",&n);
    for (int i=0;i<maxn;i++)
    {
        a[i]=i;
    }
    for (int i=0;i<n;i++)
    {
        scanf("%d",&k);
        for (int j=0;j<k;j++)
        {
            int x;
            scanf("%d",&x);
            if(ma[x]==0)
                ma[x]=++num;
            b[j]=ma[x];
            if(j)
            {
                unit(b[j],b[j-1]);
            }
        }
    }
    int cnt=0;
    for (int i=1;i<=num;i++)
    {
        a[i]=Find(i);
        if(a[i]==i)
            cnt++;
    }
    printf("%d %d\n",cnt,num);
    scanf("%d",&q);
    for (int i=0;i<q;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        int parx=Find(ma[x]);
        int pary=Find(ma[y]);
        if(parx==pary)
        {
            printf("Yes\n");
        }
        else
        {
            printf("No\n");
        }
    }
    return 0;
}