1. 程式人生 > >PAT (Advanced Level) Practice 1102 Invert a Binary Tree (25 分)樹的遍歷

PAT (Advanced Level) Practice 1102 Invert a Binary Tree (25 分)樹的遍歷

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a -

will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#include <queue>
using namespace std;
const int maxn=15;
int n;
int root;
int par[maxn];
struct node
{
    int left,right;
};
node a[maxn];
vector<int>v1,v2;
void level (int root)
{
    queue<int>q;
    q.push(root);
    while (!q.empty())
    {
        int Size=q.size();
        while (Size--)
        {
            int t=q.front();
            q.pop();
            v2.push_back(t);
            if(a[t].right!=-1)
            {
                q.push(a[t].right);
            }
            if(a[t].left!=-1)
            {
                q.push(a[t].left);
            }
        }
    }
}
void inorder(int root)
{
    if(root==-1)
    {
        return;
    }
    inorder(a[root].left);
    v1.push_back(root);
    inorder(a[root].right);
}
int main()
{
    memset (par,-1,sizeof(par));
    scanf("%d",&n);
    getchar();
    for (int i=0;i<n;i++)
    {
        char x,y;
        scanf("%c %c",&x,&y);
        getchar();
        if(x=='-')
        {
            a[i].left=-1;
        }
        else
        {
            a[i].left=x-'0';
            par[x-'0']=i;
        }
        if(y=='-')
        {
            a[i].right=-1;
        }
        else
        {
            a[i].right=y-'0';
            par[y-'0']=i;
        }
    }
    for (int i=0;i<n;i++)
    {
        if(par[i]==-1)
        {
            root=i;
            break;
        }
    }
    level(root);
    inorder(root);
    for (int i=0;i<v1.size();i++)
    {
        printf("%d%c",v2[i],i==v1.size()-1?'\n':' ');
    }
    for (int i=v1.size()-1;i>=0;i--)
    {
        printf("%d%c",v1[i],i==0?'\n':' ');
    }
    return 0;
}