1. 程式人生 > >POJ 2456 Aggressive cows(二分)

POJ 2456 Aggressive cows(二分)

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

題意:農夫有c頭牛,n個隔間,c頭牛很躁動,很容易相互打架,因此農夫想把它們分得越遠越好,要你分配隔間使得相鄰兩頭牛的距離越遠越好,問你這c頭牛分割的最小距離的最大值。

思路:二分的思想,最小距離為1,最大距離為牛欄編號最大的減去編號最小的 

AC程式碼:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,c;
long long a[100005];
int judge(int x)
{
	long long index=a[0];
	int num=1;  //當前一頭已經放進了a[0] 
	for(int i=0;i<n;i++)
	{
		if(a[i]-index>=x) 
		{
			num++;
			index=a[i];
		}
		if(num>=c) return 1; 	 
	}
	return 0;
}
void solve()
{
	int l = 1,r = a[n-1]-a[0];

	while(l<=r)
	{
		int mid=(l+r)>>1;
			//cout<<mid<<endl;
		if(judge(mid)) l=mid+1;
		else r=mid-1;
	
	}
	printf("%d\n",r);
	
}
int main()
{
	scanf("%d%d",&n,&c);
	for(int i=0;i<n;i++)
	scanf("%lld",&a[i]);
	sort(a,a+n);
	solve();
	return 0;
}