1. 程式人生 > >PAT 甲級 1002 A+B for Polynomials (25 分)

PAT 甲級 1002 A+B for Polynomials (25 分)

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2
#include<iostream>
using namespace std;
int main() {
	double N[1001] = {0}, m;
	int k, max = 0, tmp, count=0;
	for (int i = 0; i < 2; i++) {
		cin >> k;
		for (int j = 0; j < k; j++) {
			cin >> tmp >> m;
			max = tmp > max ? tmp : max;
			N[tmp] += m;
		}
	}
	for (int i = 0; i <= max; i++) {
		if (N[i] != 0)
			count++;
	}
	cout << count;
	if (count > 0) {
		for (int i = max; i >=0; i--) {
			if (N[i] != 0) {
				cout << " " << i << " ";
				printf("%0.1lf", N[i]);
			}
		}
	}
	return 0;
}