1. 程式人生 > >HDU 1686 Oulipo (hash演算法)

HDU 1686 Oulipo (hash演算法)

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2553    Accepted Submission(s): 986


 

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
 

 

 

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

 

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
 

 

 

Sample Input

3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN

 

 

Sample Output

1 3 0

hash演算法的思路就是將一個字串的每一個子串都轉化成一個整數,並且每一個不同的子串對應的數字是不一樣的,為了實現這個,我們就需要對該字串進行一個處理,就是從字串的首位開始往後一個一個的處理,這樣就能獲得從首位開始處理得每一個子串的對應的數字,但是如果我們還需要不是從首位開始的子串時該怎麼辦呢,於是就有了hash公式:

k1~ k2之間的子串對應的整數
ull ans = has[k2] - has[k1 - 1] * a[k2 - (k1 - 1)];   

比如字串1234,我們要得到34,就讓 1234-12*10^2,自己可以推一下。

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
typedef unsigned long long ull;
ull has1[10005],has2[1000005],a[1000005];//定義成這個型別可以讓它自動取模 
char s1[10005],s2[1000005];
ull sum1,sum2;
int main()
{
	int t,i,j,k,ans;
	int p=233;//一般讓基數等於233,這樣不容易出現重複 
	cin>>t;
	while(t--)
	{
		ans=0;
		scanf("%s",s1+1);//從1開始用 
		scanf("%s",s2+1);
		int len1=strlen(s1+1);
		int len2=strlen(s2+1);
		a[0]=1;//a[i]代表p的i次方 
		has1[0]=0;
		has2[0]=0;
		for(i=1;i<=len1;i++)
		has1[i]=has1[i-1]*p+s1[i];//處理從首位開始的子串 
		sum1=has1[len1];
		for(i=1;i<=len2;i++)
		{
			a[i]=a[i-1]*p;
			has2[i]=has2[i-1]*p+s2[i];
		}
		for(i=0;i+len1<=len2;i++)
		{
			sum2=has2[i+len1]-has2[i]*a[len1];//不是從首位開始的 
			if(sum1==sum2) ans++;
		}
		cout<<ans<<endl;
	}
	return 0;
}