1. 程式人生 > >POJ 1611 The Suspects(並查集小變形)

POJ 1611 The Suspects(並查集小變形)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

相對於最簡單的並查集模板,這道題需要增加一個num陣列,這個陣列用來記錄有他是幾個點的根節點(包括他自身),這樣的話,最後只需要查詢一下0的根節點,輸出num就行了,程式碼及解釋:

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
int f[30005];
int a[30005];
int s[30005];
int num[30005];
int find(int x)
{
	if(x==f[x])
	return f[x];
	else
	{
		while(x!=f[x])
		x=f[x];
		return f[x];
	}
}
void join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		f[fx]=fy;
		num[fy]+=num[fx];//fx指向了fy,所以,所有指向fx都指向了fx
	}
	
}
int main()
{
	int n,m,k,sum;
	int i,j;
	while(cin>>n>>m && n!=0 || m!=0)
	{
		int ans=0;
		for(i=0;i<=n;i++)
		{
			num[i]=1;//全部初始化為1,都只有自己指向自己
			f[i]=i;
		}
		
	
		while(m--)
		{		
			int flag=0;
			cin>>k;
			for(i=1;i<=k;i++)
			{
				cin>>a[i];
				if(a[i]==0)
				{
					flag=1;
				}
				if(i>=2)
				{
					join(a[i],a[i-1]);
				}
			}
		}
		k=find(0);
		cout<<num[k]<<endl;
	}
	return 0;
}