1. 程式人生 > >Frogger (最短路變形-求最短路上的最大權)

Frogger (最短路變形-求最短路上的最大權)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

題意:求青蛙距離,青蛙距離(人類也稱其為最小最大距離)在兩塊石頭之間,因此被定義為兩塊石頭之間所有可能的路徑之間的最小必要跳躍範圍,就是最短路上 的最大權是多少

核心:用dis[i]存從1->2的最短路徑的每段路徑的長度,通過每一步的比較求出最大權

注意:這是無向圖,因為你wrong了好幾次

程式碼:

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
#define Inf 0x3f3f3f3f
const int N=205;
struct node{
	int x,y;
}point[N];
double g[N][N];
double dis[N]; 
bool vis[N];
int n;
double Dijkstra()
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	   dis[i]=g[1][i];
	vis[1]=1;
	double Max=0;
	for(int j=1;j<n;j ++)
	{
	   	double minn=Inf;
		int u;
	   	for(int i=1;i<=n;i++)
	   	{
	   	   if(!vis[i]&&dis[i]<minn)	
	   	    {
	   	   	    u=i;
			    minn=dis[i]; 
			}
		}
		if(Max<minn) Max=minn;
		if(u==2) return Max; 
		vis[u]=1;
		for(int i=1;i<=n;i++)
		{
			if(!vis[i]&&dis[i]>g[u][i])//用dis[i]存從1->2的最短路徑的每段路徑的長度
			    dis[i]=g[u][i];
		}
	} 
}
int main()
{
	int k=1;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0) break;
		for(int i=1;i<=n;i++)
		{
			cin>>point[i].x>>point[i].y;
	    }
	    memset(g,Inf,sizeof(g));
	    for(int i=1;i<=n;i++)
	          g[i][i]=0;
	    for(int i=1;i<=n;i++)  
	       for(int j=i+1;j<=n;j++)
	       {
	       	    double t_x=(point[i].x-point[j].x)*(point[i].x-point[j].x);
	       	    double t_y=(point[i].y-point[j].y)*(point[i].y-point[j].y);
	       	    g[i][j]=g[j][i]=sqrt(t_x+t_y);//雙向可通 
		   }
		printf("Scenario #%d\n",k++);
		printf("Frog Distance = %.3f\n\n",Dijkstra());
	}
	return 0;
}