1. 程式人生 > >bfs練習 hdu1253勝利大逃亡

bfs練習 hdu1253勝利大逃亡

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,這可是Ignatius逃亡的好機會.

魔王住在一個城堡裡,城堡是一個ABC的立方體,可以被表示成A個B*C的矩陣,剛開始Ignatius被關在(0,0,0)的位置,離開城堡的門在(A-1,B-1,C-1)的位置,現在知道魔王將在T分鐘後回到城堡,Ignatius每分鐘能從一個座標走到相鄰的六個座標中的其中一個.現在給你城堡的地圖,請你計算出Ignatius能否在魔王回來前離開城堡(只要走到出口就算離開城堡,如果走到出口的時候魔王剛好回來也算逃亡成功),如果可以請輸出需要多少分鐘才能離開,如果不能則輸出-1.
在這裡插入圖片描述

Input
輸入資料的第一行是一個正整數K,表明測試資料的數量.每組測試資料的第一行是四個正整數A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它們分別代表城堡的大小和魔王回來的時間.然後是A塊輸入資料(先是第0塊,然後是第1塊,第2塊…),每塊輸入資料有B行,每行有C個正整數,代表迷宮的佈局,其中0代表路,1代表牆.(如果對輸入描述不清楚,可以參考Sample Input中的迷宮描述,它表示的就是上圖中的迷宮)

特別注意:本題的測試資料非常大,請使用scanf輸入,我不能保證使用cin能不超時.在本OJ上請使用Visual C++提交.

Output
對於每組測試資料,如果Ignatius能夠在魔王回來前離開城堡,那麼請輸出他最少需要多少分鐘,否則輸出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output
11

要求最短路徑,用bfs合適,套模版。

//
//  main.cpp
//  hdu1253bfs
//
//  Created by zhan_even on 2018/11/24.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
#include <queue>
using namespace std;
const int N = 55;

int map[N][N][N];
int dir[6][3]={{1,0,0}, {-1,0,0}, {0,1,0}, {0,-1,0}, {0,0,1}, {0,0,-1}}; //移動方向
int a,b,c,t,ans;


struct Node
{
    int x,y,z,step;
};



int bfs(Node start){
    queue<Node> q;
    Node cur, next;
    if(start.x==a-1&&start.y==b-1&&start.z==c-1){//考慮起點和終點相同的情況
        return 0;
    }

    start.step=0;
    map[start.x][start.y][start.z]=1;
    q.push(start);
    while (!q.empty()) {
        cur = q.front();//取首部元素
        q.pop();
        for (int i = 0; i < 6; i++) {
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            next.z=cur.z+dir[i][2];
            if (next.x == a-1 && next.y == b-1 && next.z == c-1 ) //寫一個就是終點
                return cur.step+1;
            if(next.x >= 0 && next.x < a && next.y >= 0 && next.y < b && next.z >= 0 &&  next.z<c)
                if(map[next.x][next.y][next.z]!=1){
                    map[next.x][next.y][next.z]=1;
                    next.step=cur.step+1;
                    q.push(next); //把next放入佇列中
                }
        }
    }
    return -1;
    
}


int main(int argc, const char * argv[]) {
    int num,i,j,k;
    Node start;
    scanf("%d", &num);
    while (num--) {
        scanf("%d %d %d %d",&a,&b,&c,&t);
        memset(map,0,sizeof(map));
        for (i = 0; i < a; i++) //輸入迷宮
            for (j = 0; j < b; j++)
                for (k = 0; k< c; k++)
                    scanf("%d", &map[i][j][k]);
        if (a + b + c - 3 > t){
            printf("-1\n");
            continue;
        }
        if(map[a-1][b-1][c-1]==1){
            printf("-1\n");
            continue;
        }
        else{
            start.x=0;
            start.y=0;
            start.z=0;
            ans = bfs(start);
            if(ans >= 0 && ans <= t)
                printf("%d\n",ans);
            
            else
                printf("-1\n");
        }
        
    }
    return 0;
}