1. 程式人生 > >POJ 3259—Wormholes

POJ 3259—Wormholes

題下:POJ 3259—Wormholes

Time Limit: 2000MS		Memory Limit: 65536K
Total Submissions: 66356		Accepted: 24748
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output

NO
YES
Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
Source

USACO 2006 December Gold

解題報告(註釋題解):

#include<iostream>
using namespace std;
const int inf=10010;
struct node{
	int f,t,c;
};
int S,E,T,N,M,W,NUM;
node n[5200];
int bellman_ford()
{
	int dis[505];
	dis[0]=0; 
	for(int i=1;i<N;i++)dis[i]=inf;//開始時設每一個點到別的點的距離無限大。就是每個點的權值 
	for(int i=1;i<N;i++)//以這個圖的點得個數為外層迴圈,,由於是從任一點開始,所以這層迴圈求的是任一點的最短距離。 
	{
		int flag=0;
		for(int j=1;j<=NUM;j++)//以有向邊的個數為內層迴圈,對每一個邊進行鬆弛。 
		{
			if(dis[n[j].t]>dis[n[j].f]+n[j].c)
			{
				dis[n[j].t]=dis[n[j].f]+n[j].c;
				flag=1;//當迴圈進不來時說明不能鬆弛了。 
			}
		}
		if(!flag)break;//不能鬆弛就跳出迴圈。 
	}
	for(int i=1;i<=NUM;i++)
	{
		if(dis[n[i].t]>dis[n[i].f]+n[i].c)
		return true;
	}
	return false;
}
int main()
{
	int nn;
	cin>>nn;
	while(nn--)
	{
		NUM=1;
		cin>>N>>M>>W;
		while(M--)
		{
			cin>>S>>E>>T;
			n[NUM].f=S;
			n[NUM].t=E;
			n[NUM++].c=T;//無向邊,故需要將兩個方向都記下。 
			n[NUM].f=E;
			n[NUM].t=S;
			n[NUM++].c=T;
		}
		while(W--)
		{
			cin>>S>>E>>T;
			n[NUM].f=S;
			n[NUM].t=E;
			n[NUM++].c=(0-T);
		}
		if(bellman_ford())
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}
	return 0;
}