1. 程式人生 > >HDU-2602-Bone Collector(01揹包+dp)

HDU-2602-Bone Collector(01揹包+dp)

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

分析:01揹包問題,動態方程:dp[j] = max(dp[j],dp[j-b[i]]+a[i])

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 1005
int a[maxn],b[maxn];
int dp[maxn];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d %d",&n,&m);
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(dp,0,sizeof(dp));
		for(int i = 1; i <= n; i ++)
			scanf("%d",&a[i]);
		for(int i = 1; i <= n; i ++)
			scanf("%d",&b[i]);
		for(int i = 1; i <= n; i ++)
			for(int j = m; j >= b[i]; j--)
			{
				dp[j] = max(dp[j],dp[j-b[i]]+a[i]);
			 } 
		printf("%d\n",dp[m]);
	}
	
}