1. 程式人生 > >HDU 2594 Simpsons’ Hidden Talents (字串-KMP 字首與字尾)

HDU 2594 Simpsons’ Hidden Talents (字串-KMP 字首與字尾)

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15010    Accepted Submission(s): 5148


 

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

 

 

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

 

 

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

 

 

Sample Input

 

clinton homer riemann marjorie

 

 

Sample Output

 

0 rie 3

 

 

Source

HDU 2010-05 Programming Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1686

 2595 2596 2597 2598 

 

哈哈哈哈,終於自己做出了演算法題了。

直接把這兩個字串合併起來就行,但有一點要注意就是比如

abc abcabc
abcabc 6

所以應該限制一下長度,不能超過原本字串的長度

但是,發現了一組資料不對,但其他做法也不對,

abc dabcd  這個應該輸出0  結果是輸出abc 3

後面程式碼可以解決此錯誤。

資料水啊

程式碼實現:能AC但最後一個樣例沒過

#include<cstdio>
#include<iostream>
#include<fstream>
#include<algorithm>
#include<functional>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<numeric>
#include<cctype>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
 
const int N = 1000002;
int nxt[N];
string S,T,T1;
int  tlen;
 
void getNext()
{
    int j, k;
    j = 0; k = -1;
	nxt[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
           {
           	nxt[++j] = ++k;
           	if (T[j] != T[k]) 
				nxt[j] = k; 
           } 
        else
            k = nxt[k];
 
}


int main()
{
 
	
    while(cin>>T1>>S)
    {
         T=T1+S;
    	tlen= T.length();
		getNext();
		if(nxt[tlen]==0)
		{
		printf("0\n") ;
		continue;
		}
		int ans=min(T1.length(),S.length());
		if(nxt[tlen]<=T1.length()&&nxt[tlen]<=S.length())
			ans=nxt[tlen];
		cout<<T.substr(0,ans)<<" "<<ans<<endl;
	
       	 
    }
    return 0;
}
 

可以過最後一個樣例

#include<cstdio>
#include<iostream>
#include<fstream>
#include<algorithm>
#include<functional>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<numeric>
#include<cctype>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
 
const int N = 1000002;
int nxt[N];
string S,T,T1;
int  tlen;
 
void getNext()
{
    int j, k;
    j = 0; k = -1;
	nxt[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
           {
           	nxt[++j] = ++k;
           	if (T[j] != T[k]) 
				nxt[j] = k; 
           } 
        else
            k = nxt[k];
 
}


int main()
{
 
	
    while(cin>>T1>>S)
    {
         T=T1+S;
    	tlen= T.length();
		getNext();
		
		int minn=min(T1.length(),S.length());
		int index=nxt[tlen];
		
		 while (index>minn)//若超出長度 
                index=nxt[index];//向前迭代尋找 
			
		if(index==0)
		{
		printf("0\n") ;
		continue;
		}
		cout<<T.substr(0,index)<<" "<<index<<endl;
	
       	 
    }
    return 0;
}